Parsoid failures trying to save or preview posts with @ mentions on mw.org (curl error: 26)
Closed, ResolvedPublic

Description

In Firefox or Chromium, I visit Talk:Flow on mw.org, click Reply under a post, and enter something that includes an @mention, like "@foo Thank you". When I click the "and you can preview" link at the bottom I get a pink "Unable to parse content due to a Parsoid failure." I get similar errors if I try to reply, or switch to Visual Editor. If I remove the @, these work OK.

The API response has

{
  "servedby": "mw1117",
  "error": {
    "code": "internal_api_error_Flow\\Exception\\NoParserException",
    "info": "[a4d7fce4] Exception Caught: Request to parsoid for 'wikitext' to 'html' conversion of content connected to title \"Talk:Flow\" failed: (curl error: 26)"
  }
}
Spage created this task.Nov 6 2015, 2:19 AM
Spage updated the task description. (Show Details)
Spage raised the priority of this task from to High.
Spage added a subscriber: Spage.
Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptNov 6 2015, 2:19 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

Can be reproduced on Terbium easily:

mattflaschen@terbium:~$ mwscript eval.php --wiki=mediawikiwiki
> var_export( Flow\Parsoid\Utils::convert( 'wikitext', 'html', 'Mattflaschen', Title::newMainPage() ) );
'<p data-parsoid=\'{"dsr":[0,12,0,0]}\'>Mattflaschen</p>'
> ^D
mattflaschen@terbium:~$ mwscript eval.php --wiki=mediawikiwiki
> var_export( Flow\Parsoid\Utils::convert( 'wikitext', 'html', '@Mattflaschen', Title::newMainPage() ) );
Caught exception Flow\Exception\NoParserException: Request to parsoid for 'wikitext' to 'html' conversion of content connected to title "MediaWiki" failed: (curl error: 26)
#0 /srv/mediawiki/php-1.27.0-wmf.5/extensions/Flow/includes/Parsoid/Utils.php(39): Flow\Parsoid\Utils::parsoid('wikitext', 'html', '@Mattflaschen', Object(Title))
#1 /srv/mediawiki/php-1.27.0-wmf.5/maintenance/eval.php(78) : eval()'d code(1): Flow\Parsoid\Utils::convert('wikitext', 'html', '@Mattflaschen', Object(Title))
#2 /srv/mediawiki/php-1.27.0-wmf.5/maintenance/eval.php(78): eval()
#3 /srv/mediawiki/multiversion/MWScript.php(97): require_once('/srv/mediawiki/...')
#4 {main}

Can not be reproduced at http://parsoid-lb.eqiad.wikimedia.org/_wikitext/

Did not get beyond that.

It's probably specific to one of Parsoid's APIs, but the client could be encoding it wrong. It might also be an issue that only occurs with one of Parsoid's API versions.

Catrope added a subscriber: Catrope.Nov 6 2015, 7:52 PM

From Googling around, curl error 26 appears to be "failed creating formpost data", and a mailing list post that I found (that wasn't responded to) talked about experiencing this error with a value starting with @ as well. I'll dig in a bit deeper but it sounds like this isn't on the Parsoid side.

Oh yeah, in command-line cURL, @ means filename. I didn't realize that also affected the library.

Catrope claimed this task.Nov 6 2015, 8:54 PM
Krenair added a subscriber: Krenair.Nov 6 2015, 9:09 PM

What is this blocked on?

I would like to note that this also prevented me from saving a comment, not only preview.

Mattflaschen-WMF renamed this task from Parsoid failures trying to preview posts with @ mentions on mw.org (curl error: 26) to Parsoid failures trying to save or preview posts with @ mentions on mw.org (curl error: 26).Nov 12 2015, 12:39 AM

Should be fixed in production now (but not in beta yet)

Checked in mw.org - the issue is fixed.

Betalabs still has the issue.

Catrope closed this task as Resolved.Dec 4 2015, 1:12 AM