Page MenuHomePhabricator

API requests fail to load captcha information for some requests
Closed, ResolvedPublic1 Story Points

Description

When an anonymous or non-autoconfirmed user tries to insert an external link with VE, the "Save" dialogue displays a CAPTCHA code. However, even if the CAPTCHA is inserted correctly, dialogue shows another CAPTCHA code and so on, so the user cannot save his work. It happens with Chrome 46 and Firefox 42.

Details

Related Gerrit Patches:
mediawiki/extensions/ConfirmEdit : wmf/1.27.0-wmf.5Copy context request changes to wgRequest global
mediawiki/extensions/ConfirmEdit : masterCopy context request changes to wgRequest global

Event Timeline

Nnvu created this task.Nov 6 2015, 11:41 PM
Nnvu raised the priority of this task from to Needs Triage.
Nnvu updated the task description. (Show Details)
Nnvu added a project: VisualEditor.
Nnvu added a subscriber: Nnvu.
Restricted Application added subscribers: StudiesWorld, Aklapper. · View Herald TranscriptNov 6 2015, 11:41 PM
Catrope triaged this task as Unbreak Now! priority.Nov 6 2015, 11:43 PM
Catrope added a subscriber: Catrope.

Confirmed on enwiki with Chrome in incognito mode

Krenair added a subscriber: Krenair.

Usually helpful to at least CC me on these things if you're not going to add VisualEditor-MediaWiki. I only noticed this because of the feed on IRC

Krenair renamed this task from Dialogue asks CAPTCHA even if inserted correctly to API requests fail to load captcha information for some requests (anonymous users?).Nov 7 2015, 12:21 AM
Krenair set Security to None.
Restricted Application added a subscriber: Florian. · View Herald TranscriptNov 7 2015, 12:21 AM
Krenair claimed this task.Nov 7 2015, 12:21 AM

Usually helpful to at least CC me on these things if you're not going to add VisualEditor-MediaWiki. I only noticed this because of the feed on IRC

Sorry. I was going to investigate this myself, but I got a phone call and had to run.

Change 251672 had a related patch set uploaded (by Alex Monk):
Copy context request changes to wgRequest global

https://gerrit.wikimedia.org/r/251672

Change 251672 merged by jenkins-bot:
Copy context request changes to wgRequest global

https://gerrit.wikimedia.org/r/251672

Change 251673 had a related patch set uploaded (by Jforrester):
Copy context request changes to wgRequest global

https://gerrit.wikimedia.org/r/251673

Jdforrester-WMF closed this task as Resolved.Nov 7 2015, 1:01 AM
Jdforrester-WMF edited projects, added Contributors-Team; removed Patch-For-Review.
Jdforrester-WMF added a subscriber: Jdforrester-WMF.

Will back-port for Monday.

Quiddity renamed this task from API requests fail to load captcha information for some requests (anonymous users?) to API requests fail to load captcha information for some requests.Nov 8 2015, 8:35 PM
Quiddity updated the task description. (Show Details)

Change 251673 merged by jenkins-bot:
Copy context request changes to wgRequest global

https://gerrit.wikimedia.org/r/251673

@Quiddity pointed out some other reports of it affecting logged in users, so I deployed the fix early. Apparently it works now.

Thanks @Krenair for the fast deployment and fix for this problem :)