Page MenuHomePhabricator

OAuth broken
Closed, ResolvedPublic

Description

Getting a token for authorization from OAuth appears to be broken at the moment:
https://tools.wmflabs.org/widar/index.php?action=authorize

"
Error
Our servers are currently experiencing a technical problem. This is probably temporary and should be fixed soon.
Please try again in a few minutes.
"

OAuth problems were reported at least 2h ago, so...

Event Timeline

Magnus created this task.Nov 11 2015, 8:32 AM
Magnus raised the priority of this task from to Unbreak Now!.
Magnus updated the task description. (Show Details)
Magnus added a subscriber: Magnus.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 11 2015, 8:32 AM
Joe claimed this task.Nov 11 2015, 9:14 AM

I confirmed OAuth is broken and the reason is the following:

Fatal error: $this is null in /srv/mediawiki/php-1.27.0-wmf.6/extensions/OAuth/backend/MWOAuthRequest.php on line 71

Investigating further.

Joe added a comment.Nov 11 2015, 9:22 AM

@Glasher you're right, that is the problem indeed.

Change 252407 had a related patch set uploaded (by Giuseppe Lavagetto):
Fix MWOAuthRequest::fromRequest logging

https://gerrit.wikimedia.org/r/252407

Change 252407 merged by jenkins-bot:
Fix MWOAuthRequest::fromRequest logging

https://gerrit.wikimedia.org/r/252407

Change 252408 had a related patch set uploaded (by 20after4):
Fix MWOAuthRequest::fromRequest logging

https://gerrit.wikimedia.org/r/252408

Change 252408 merged by jenkins-bot:
Fix MWOAuthRequest::fromRequest logging

https://gerrit.wikimedia.org/r/252408

jcrespo reopened this task as Open.Nov 11 2015, 9:50 AM
jcrespo added a subscriber: jcrespo.

Change 252412 had a related patch set uploaded (by Giuseppe Lavagetto):
Fixup for Ib9b800d3d7ddd095856c5deaf88be82d64db0fb8

https://gerrit.wikimedia.org/r/252412

Change 252413 had a related patch set uploaded (by 20after4):
Fixup for Ib9b800d3d7ddd095856c5deaf88be82d64db0fb8

https://gerrit.wikimedia.org/r/252413

Change 252413 merged by jenkins-bot:
Fixup for Ib9b800d3d7ddd095856c5deaf88be82d64db0fb8

https://gerrit.wikimedia.org/r/252413

mmodell reopened this task as Open.Nov 11 2015, 9:58 AM
Joe added a comment.Nov 11 2015, 9:59 AM

@Magnus my tests show that this is now resolved, can you confirm?

Joe added a comment.Nov 11 2015, 10:02 AM

I tested a few applications and OAuth seems to be back.

Joe closed this task as Resolved.Nov 11 2015, 10:02 AM

Change 252412 merged by Giuseppe Lavagetto:
Fixup for Ib9b800d3d7ddd095856c5deaf88be82d64db0fb8

https://gerrit.wikimedia.org/r/252412

Restricted Application added subscribers: Jay8g, TerraCodes. · View Herald TranscriptJun 7 2017, 6:46 PM