Page MenuHomePhabricator

Missing page id in the recentchanges list of https://commons.wikimedia.org/ for some upload logevents.
Closed, ResolvedPublic

Description

The first entry in
https://commons.wikimedia.org/w/api.php?action=query&list=recentchanges&rcstart=1447294706

{
              "type": "log",
              "ns": 6,
              "title": "File:Horses, asses, zebras, mules and mule breeding BHL22987617.jpg",
              "pageid": 0,
              "revid": 0,
              "old_revid": 0,
              "rcid": 185433577,
              "timestamp": "2015-11-12T02:18:26Z"
},

and
https://commons.wikimedia.org/w/api.php?action=query&list=logevents&letype=upload&lestart=1447294706

{
              "logid": 142904427,
              "ns": 6,
              "title": "File:Horses, asses, zebras, mules and mule breeding BHL22987617.jpg",
              "pageid": 44951940,
              "logpage": 44951940,
              "params": {
                  "img_sha1": "kg6r23d4tw5fwb23qwxvdg3buw5h5l8",
                  "img_timestamp": "2015-11-12T02:18:26Z"
              },
              "type": "upload",
              "action": "upload",
              "user": "F\u00e6",
              "timestamp": "2015-11-12T02:18:26Z",
              "comment": "== {{int:filedesc}} ==\n{{BHL\n| source = http://www.biodiversitylibrary.org/pageimage/22987617\n| description = Horses, asses, zebras, mules and mule breeding /  by W.B. Tegetmeier and C.L. Sutherland.\n| pageid = 22987617\n| itemid = 74389\n| titleid = 306..."
},

are describing same event, but the first one's pageid is 0. Is that an intended behavior?

Event Timeline

LinJin created this task.Nov 12 2015, 3:01 AM
LinJin raised the priority of this task from to Needs Triage.
LinJin updated the task description. (Show Details)
LinJin added a subscriber: LinJin.
Restricted Application added subscribers: StudiesWorld, Steinsplitter, Aklapper. · View Herald TranscriptNov 12 2015, 3:01 AM
Krenair added a subscriber: Krenair.

Looking at the code... Does this seem to depend on whether it's an overwrite (of an existing image) or a new upload?

Restricted Application added projects: Multimedia, Commons. · View Herald TranscriptNov 12 2015, 3:16 AM

This happens only in recent 8 hours, so I do not think it depends on whether it is an overwrite. Is there anything happening in recent 8 hours?

Restricted Application added a subscriber: Matanya. · View Herald TranscriptNov 12 2015, 3:19 AM

Change 252625 had a related patch set uploaded (by Aaron Schulz):
Move down $logEntry publish() call in recordUpload2()

https://gerrit.wikimedia.org/r/252625

Steinsplitter moved this task from Incoming to Backlog on the Commons board.Nov 12 2015, 12:11 PM
Jdforrester-WMF triaged this task as High priority.
Jdforrester-WMF moved this task from Untriaged to Doing on the Multimedia board.
Jdforrester-WMF set Security to None.

Change 252625 merged by Aaron Schulz:
Move down $logEntry publish() call in recordUpload2()

https://gerrit.wikimedia.org/r/252625

What's the state of this issue?

Fix should be deployed now... Please check that recentchanges made today do not have this issue

LinJin closed this task as Resolved.Nov 20 2015, 2:56 AM

Thanks very much. In recent 6 hours, we did not detected any such recentchanges.