Page MenuHomePhabricator

Rename "DataType" to "PropertyType" across the code base and documentation.
Open, LowPublic

Description

"data type" is a very unclear term, and it's not obvious how it would be different from a "value type". "Property type" is much more descriptive, since it actually defines the type of a property.

Event Timeline

daniel created this task.Nov 12 2015, 9:02 PM
daniel raised the priority of this task from to Needs Triage.
daniel updated the task description. (Show Details)
daniel added a project: Wikidata.
daniel added a subscriber: daniel.
Restricted Application added subscribers: StudiesWorld, Aklapper. · View Herald TranscriptNov 12 2015, 9:02 PM

We have trained people on datatype now and it is all our user-facing documentation. I think changing this now to introduce yet another term creates more confusion than it resolves.

thiemowmde triaged this task as Low priority.Mar 26 2017, 3:27 PM
thiemowmde added a project: patch-welcome.
thiemowmde added a subscriber: thiemowmde.

I believe the fact that we have a concept called "data type" always was and still is an issue. A minor one, but still. Even I, as one of the senior developers, always struggle when explaining the difference between "data type" and "data value type".

I agree it's of not much value to go around and change one term to the other. But we should make sure we are preferring more descriptive vocabulary when introducing new code. In code documentation and variable names we are doing this and slowly moving towards "property data type" whenever it makes sense.

We have trained people on datatype now and it is all our user-facing documentation. I think changing this now to introduce yet another term creates more confusion than it resolves.

/me agrees

I believe the fact that we have a concept called "data type" always was and still is an issue. A minor one, but still. Even I, as one of the senior developers, always struggle when explaining the difference between "data type" and "data value type".

I agree it's of not much value to go around and change one term to the other. But we should make sure we are preferring more descriptive vocabulary when introducing new code. In code documentation and variable names we are doing this and slowly moving towards "property data type" whenever it makes sense.

/me also agrees in part

We will always have the term "DataType" unless we want to make breaking changes, for example, it is in our API output, and a bunch of other places

Had we done this when we first thought of the name change it may have made sense, but it would be quite a shake up now for code using wikibase and also peoples knowledge of wikibase.
We could try to come up with some migration plan but I honestly don't think it is worth it.

@thiemowmde thoughts?
I'll check back soon and potentially close this ticket

Addshore changed the task status from Open to Stalled.Jul 12 2018, 3:40 PM
Addshore added a project: User-Addshore.
Addshore moved this task from Unsorted 💣 to Blocked 🚧 on the User-Addshore board.

Personally, I don't think it makes sense to touch the string datatype in any machine-readable output. (In other words: I don't think this is worth a breaking change.) But I think it makes sense to prefer $propertyType as a variable name in code, and "property data type" in documentation. Especially the later. What can you loose if you do this?

Personally, I don't think it makes sense to touch the string datatype in any machine-readable output. (In other words: I don't think this is worth a breaking change.) But I think it makes sense to prefer $propertyType as a variable name in code, and "property data type" in documentation. Especially the later. What can you loose if you do this?

$propertyType or $propertyDataType?

"property data type" in docs definitely sounds like a good idea.

Aklapper changed the task status from Stalled to Open.Fri, May 22, 4:54 PM

Questoins have been answered, hence resetting task status from Stalled to Open.