Page MenuHomePhabricator

[Bug] Cannot type "ô" in value field when adding a statement
Closed, ResolvedPublic

Description

On an azerty keyboard, to type an "ô", you have to type "^" and then "o". It works well on the property input field, but on the value input field, it gives "^o".

(reported on contact the dev team page)

Event Timeline

Lydia_Pintscher raised the priority of this task from to Normal.
Lydia_Pintscher updated the task description. (Show Details)
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 13 2015, 1:40 PM

Works for me with Firefox on Debian with qwertz using de layout, which uses the same way to compose ô. What operating system and browser are you using? What property did that occur with?

Ayack added a comment.Nov 14 2015, 6:37 PM

I have this problem with Firefox 42.0 on Mac OS X on every property (P31 for example) but it works well with Safari...

Wikibase does not have code that could affect the composition feature of the operating systems keyboard driver, but the Universal Language Selector (ULS) does have such code. Can you please check if the ULS "input settings" match your language? Can you please try to disable all input tools in ULS?

ULS "input settings" say that "No input methods are available for this language." (French). I disabled it (even if I never activated it) and I have the same issue.

Yep, I confirm the exact same problem. when trying to type words with ^ accent (like forêt) or ¨ (like naïade), the classic typing method does not work in properties and labels of an item, while it works perfectly in the discussion pages.

I also work on Firefox (last version) on a Mac OSX, and that problem appeared not very long ago. It is very annoying in French poetry than involve many accents, and accented capitals.
My default (system) typing method is French.

I have exactly the same messages as Ayack. :/

hoo added a subscriber: hoo.Aug 14 2016, 4:44 PM

@Hsarrazin @Ayack Is this still a problem for you? I can't reproduce this on Linux at all (neither with Firefox nor with WebKit based browsers).

Ayack added a comment.Aug 25 2016, 6:05 PM

@Hsarrazin @Ayack Is this still a problem for you? I can't reproduce this on Linux at all (neither with Firefox nor with WebKit based browsers).

I can't reproduce it either. Seems to be solved. Thanks.

Lydia_Pintscher closed this task as Resolved.Aug 25 2016, 6:21 PM
Lydia_Pintscher claimed this task.