Page MenuHomePhabricator

Sharing a pic with a fragment of an article doesn't work on Huawei P8 lite
Closed, ResolvedPublic1 Story Points

Description

Description

The functionality works as a charm on my other mobile phone. However, on Huawei P8 Lite it simply doesn't work as it should (both in main and beta versions of the android app).

Steps to reproduce

  1. Mark some words to be shared
  2. A popup bar shows up with options to copy the text to clipboard, share it, translate it, look it up on Wikipedia and search for it. When I choose "Share", a popup shows up with numerous apps I could send the resulting picture (until this moment everything works as designed)
  3. Regardless of my choice, the pic+text picture doesn't get created. There is no option to "save as picture", so I can't check whether it's a problem with creating the pic in the first place or with sharing it. When I chose Facebook, an empty Facebook status field is opened, I can fill in the text, but there's no picture there. If I chose Snapchat, the app is opened, I can chose the recipients, and when I do, they get only the text sent as a chat message and not a snap. Same for sms messages (text is pre-filled in the sms typing window, but no picture), native email app, Gmail app, Google+ app and others.

Expected results

Picture+text created and sent to the app of choice for sharing, or saved to mobile phone.

Actual results

As above

Environments observed

App version: 2.1.134-beta-2015-11-12; 2.1.133-r-2015-10-26
Android OS versions: 5.0
Device model: ALE-L21 (Huawei P8 Lite)
Device language: pl

Related Objects

Event Timeline

Halibutt raised the priority of this task from to Needs Triage.
Halibutt updated the task description. (Show Details)
Halibutt added a subscriber: Halibutt.
Restricted Application added subscribers: StudiesWorld, Aklapper. · View Herald TranscriptNov 15 2015, 7:47 PM

Thinking of it now, I believe the issue has something to do with Wikipedia app being incompatible with EMUI add-on pre-installed on most Huawei phones these days (or the other way around). Ever since reporting this issue I updated my phone, but the share a fact function still doesn't work. Android 5.0.1, EMUI 3.1.

Ok, here's how it works in pictures. Perhaps someone could make something out of this. I select the text for sharing in some article the normal way. The article obviously has pictures.

The options are, L2R, mark, copy, share, translate, Wikipedia, search. When "share" is tapped, I get a window with several screens of icons of apps I could share the snippet through. All the usual suspects are there: copy to clipboard, Facebook, Messenger, Snapchat, Email, Diaspora, Hangouts, Google+, even Wikipedia and Wikipedia Beta apps.

What follows depends on the app I chose. When FB is chosen, I get a clean sharing screen, no text is inserted, let alone picture. In Messenger i get the screen where I can chose whom to message, yet when I chose someone only the highlighted text is sent. When I chose Twitter, Snapchat or any of the mail (native app, gmail, inbox) or sms apps (native, Signal) at least the highlighted text is pasted (no pic though). Save to disk option opens up a screen where I can save the snippet as a .txt file.

Any ideas what could I check in order to help solve this issue?

MBinder_WMF set the point value for this task to 1.May 18 2016, 7:28 PM
Halibutt closed this task as Resolved.EditedOct 26 2016, 2:43 PM
Halibutt claimed this task.

It seems the problem was indeed with the EMUI addon, matter got solved with the latest update to EMUI 4.0 (ALE-L21C09B577).