Page MenuHomePhabricator

Template: Input for template name always marked as invalid, even if template exist
Closed, ResolvedPublic1 Estimated Story Points

Description

See image:

Steps to reproduce:

  • Open a page on mediawiki.org
  • Start editing with VE (using the "Edit" button)
  • Click "Insert" -> "Template" or type "{{" to open the Template dialog
  • Type in the name of an existing template into the template name input box or select the name of the suggestions

Expected result:
The input box has a blue indicator

Observed result:
The input box has a red indicator, which should indicate, that the template currently does not exist.

Event Timeline

Florian raised the priority of this task from to Needs Triage.
Florian updated the task description. (Show Details)
Florian added a project: VisualEditor.
Florian added a subscriber: Florian.

Adding OOUI, it seems to be a problem with the latest release, because I see this on Special:MovePage, too. For the new title input, which should never be red.

Looks like the validation function isn't being set up properly

Due to the order in which we call mw.widgets.TitleInputWidget.parent and mw.widgets.TitleWidget in mw.widgets.TitleInputWidget's constructor
Edit: Well, not quite.

Jdforrester-WMF added a subscriber: DLynch.

Change 254296 had a related patch set uploaded (by Florianschmidtwelzow):
Fix conflicting configuration name in TitleInputWidget

https://gerrit.wikimedia.org/r/254296

Change 254296 merged by jenkins-bot:
Fix conflicting configuration name in TitleInputWidget

https://gerrit.wikimedia.org/r/254296

Change 254307 had a related patch set uploaded (by Florianschmidtwelzow):
Fix conflicting configuration name in TitleInputWidget

https://gerrit.wikimedia.org/r/254307

Change 254307 merged by jenkins-bot:
Fix conflicting configuration name in TitleInputWidget

https://gerrit.wikimedia.org/r/254307

Jdforrester-WMF removed a project: Patch-For-Review.
Jdforrester-WMF edited a custom field.