Page MenuHomePhabricator

Spike: [2 hours] QuickSurvey schema did not create a table in log database from first survey
Closed, ResolvedPublic

Description

It's not clear if this was intended behavior (because it was an external survey) or not. If it's a bug, it could be an issue for the upcoming Discovery survey and potential for multiple-choice (internal) surveys in the future.

Event Timeline

atgo created this task.Nov 20 2015, 12:09 AM
atgo raised the priority of this task from to Needs Triage.
atgo updated the task description. (Show Details)
atgo added a project: QuickSurveys.
atgo added subscribers: atgo, leila, MSyed and 2 others.
Restricted Application added subscribers: StudiesWorld, Aklapper. · View Herald TranscriptNov 20 2015, 12:09 AM

@JKatzWMF can we bring this into the kickoff queue for sprint C?

@jhobs yes, let's do this

jhobs updated the task description. (Show Details)Nov 20 2015, 1:57 PM
KLans_WMF renamed this task from QuickSurvey schema did not create a table in log database from first survey to Spike: [2 hours] QuickSurvey schema did not create a table in log database from first survey.Nov 23 2015, 5:49 PM
KLans_WMF triaged this task as High priority.Nov 23 2015, 6:13 PM
bmansurov moved this task from To Do to Doing on the Reading Web Sprint 61 - Cold Hard Cache board.

Turns out, unlike internal surveys, external surveys are not set up to log events (compare [1] and [2]). I couldn't dig up a reason why. I'll create a patch that logs external survey events.

[1] https://github.com/wikimedia/mediawiki-extensions-QuickSurveys/blob/master/resources/ext.quicksurveys.views/QuickSurvey.js#L137
[2] https://github.com/wikimedia/mediawiki-extensions-QuickSurveys/blob/master/resources/ext.quicksurveys.views/ExternalSurvey.js#L49

Change 255100 had a related patch set uploaded (by Bmansurov):
Log external survey responses

https://gerrit.wikimedia.org/r/255100

Change 255100 merged by jenkins-bot:
Log user interactions with external surveys

https://gerrit.wikimedia.org/r/255100

phuedx closed this task as Resolved.Nov 27 2015, 1:45 PM
phuedx added a subscriber: phuedx.

Confirmed that events are being logged when I interact with an external survey on reading-web-staging.