Page MenuHomePhabricator

Regression: wgRelatedArticlesShowReadMore defaults to false on wikivoyage
Closed, ResolvedPublic

Description

On https://en.wikivoyage.org/wiki/New_York_City you'll see the historical "Related pages" menu item in the left menu (note this is DESKTOP).
It's not showing up in http://en.wikivoyage.beta.wmflabs.org/wiki/Related_test
as it's being controlled by wgRelatedArticlesShowReadMore which is defaulting to false

The historical menu item should be determined by a separate configuration variable and not be controlled by wgRelatedArticlesShowReadMore

  • It should be possible to enable read more (footer via beta features) but disable the left menu behaviour (e.g. for English Wikipedia)
  • If read more footer and left menu are both enabled on Vector I see both (for time being until features have been consolidated - needed by Wikivoyage)
  • If read more (footer) is enabled and related articles (left menu) is enabled but I do not have the beta feature enabled then I see the links in the left menu.
  • If read more (footer) is enabled and related articles (left menu) is disabled but I do not have the beta feature enabled then I see no links in the left menu and no links in the footer.
  • If read more (footer) is disabled and related articles (left menu) is disabled I see nothing.

Introduced by T117444

Details

Related Gerrit Patches:
mediawiki/extensions/RelatedArticles : devConfigure footer and sidebar placements
mediawiki/extensions/RelatedArticles : devCorrectly show related articles on desktop

Event Timeline

Jdlrobson created this task.Dec 1 2015, 1:24 AM
Jdlrobson raised the priority of this task from to High.
Jdlrobson updated the task description. (Show Details)
Jdlrobson added a subscriber: Jdlrobson.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 1 2015, 1:24 AM

The historical menu item should be determined by a separate configuration variable and not be controlled by wgRelatedArticlesShowReadMore

Since both ReadMore and historical menu show the same information, wouldn't it make more sense to show either?

Change 256166 had a related patch set uploaded (by Bmansurov):
Correctly show related articles on desktop

https://gerrit.wikimedia.org/r/256166

phuedx added a subscriber: phuedx.Dec 1 2015, 10:37 AM

The historical menu item should be determined by a separate configuration variable and not be controlled by wgRelatedArticlesShowReadMore

See 253919 and 253920.

Seeking another reviewer /cc @Jdlrobson @jhobs

Change 253920 had a related patch set uploaded (by Jdlrobson):
Configure footer and sidebar placements

https://gerrit.wikimedia.org/r/253920

Jdlrobson updated the task description. (Show Details)Dec 2 2015, 2:06 AM

Change 256166 merged by jenkins-bot:
Correctly show related articles on desktop

https://gerrit.wikimedia.org/r/256166

Jdlrobson updated the task description. (Show Details)Dec 2 2015, 2:09 AM

Merged Baha's patch but Sam's patch (https://gerrit.wikimedia.org/r/253920) is needed to call this complete.

Jdlrobson reassigned this task from bmansurov to phuedx.Dec 2 2015, 2:09 AM
phuedx updated the task description. (Show Details)Dec 2 2015, 12:18 PM

It should be possible to enable read more (footer via beta features) but disable the left menu behaviour (e.g. for English Wikipedia)

This is possible as of T119926#1843662.

Change 253920 merged by jenkins-bot:
Configure footer and sidebar placements

https://gerrit.wikimedia.org/r/253920

Jdlrobson closed this task as Resolved.Dec 2 2015, 11:01 PM