Page MenuHomePhabricator

Bug: Cannot edit Portal pages (and other non-mainspace pages?)
Closed, ResolvedPublic

Description

Description

Attempting to edit Portal pages shows an erroneous "cannot connect to the internet" message.

Steps to reproduce

  1. Search for "Portal:Communism"
  2. Attempt to edit

Expected results

The edit screen appears

Actual results

"cannot connect to the internet" appears

Environments observed

App version: Current master dev
Android OS versions: 6.0
Device model: Nexus 6P
Device language: English

Event Timeline

Mholloway created this task.Dec 3 2015, 4:58 PM
Mholloway raised the priority of this task from to Needs Triage.
Mholloway updated the task description. (Show Details)
Mholloway added a subscriber: Mholloway.
Restricted Application added subscribers: StudiesWorld, Aklapper. · View Herald TranscriptDec 3 2015, 4:58 PM

So... the new app update has been released, and nobody has taken a look at this?

Dbrant added a subscriber: Dbrant.Jan 18 2016, 11:44 PM

@Lbertolotti I don't see this issue if I tap the topmost edit pencil (above the "Communism and Marxism" header). It's only when I tap the other pencils that the error occurs. Can you confirm this?

I'm guessing that this is because this portal (and others like it) include a lot of templates that expand into their own "Sections" that break the mobileview API. Therefore, this bug won't realistically be fixed anytime soon, since it will require work on the backend. But, again, you should be able to tap the topmost pencil to edit the page.

@Lbertolotti I don't see this issue if I tap the topmost edit pencil (above the "Communism and Marxism" header). It's only when I tap the other pencils that the error occurs. Can you confirm this?

Confirmed.

Lbertolotti closed this task as Resolved.Apr 9 2016, 3:38 AM
Lbertolotti claimed this task.

Problem solved. Now the code can be edited. Can we edit the code to resize the portal boxes to fit my cellphone screen?

The boxes are displaying fine on my cellphone (Nexus 5), I'm not sure about other models.