Page MenuHomePhabricator

Regression: Sprint projects now display project board instead of sprint board by default
Closed, ResolvedPublic

Assigned To
None
Authored By
atgo
Dec 3 2015, 5:40 PM
Tokens
"Heartbreak" token, awarded by Niharika."Dislike" token, awarded by Jdforrester-WMF."Like" token, awarded by DStrine."Like" token, awarded by MBinder_WMF."Heartbreak" token, awarded by KLans_WMF.

Description

Previously, clicking on a sprint project brought you to the sprint board instead of the project board. Now it's the other way around, which is a lot of extra clicking.
Ex project board: https://phabricator.wikimedia.org/tag/fundraising_sprint_yo_la_tengo/
Ex sprint board: https://phabricator.wikimedia.org/project/sprint/board/1646/

Event Timeline

atgo created this task.Dec 3 2015, 5:40 PM
atgo raised the priority of this task from to Needs Triage.
atgo updated the task description. (Show Details)
atgo added subscribers: atgo, Qgil, Aklapper and 2 others.
Restricted Application added subscribers: StudiesWorld, scfc. · View Herald TranscriptDec 3 2015, 5:40 PM
MBinder_WMF added a subscriber: MBinder_WMF.
MBinder_WMF added a comment.EditedDec 7 2015, 6:56 PM

Easy (temporary fix): Find the project via the "Projects" link on the main Phabricator page, and click it. Change the URL from, for example,
https://phabricator.wikimedia.org/project/view/1655/
to
https://phabricator.wikimedia.org/project/sprint/board/1655/

You can also create a custom dashboard with a text link.

Neither of these is a sustainable solution, but works in a pinch.

Credit: @DStrine

Yeah I can definitely access the board, it's just annoying. Thanks for the
workaround. Any idea when this might get fixed?

Another way to get there (many extra clicks): navigate to the correct board by clicking the project, then the project profile, then "view sprint board" from the options on the right.

I should add that this is especially annoying when you're working actively on updating tasks in a sprint project. Navigating back to the board from updates is something I often do by clicking the project name in the "projects" list because hitting back in the browser goes back through the editing flow. Now there's no good way to get back to the sprint view.

BTW, I found this restoration of expected behaviour really helpful. I'd be sad for the 'regression' to be 'fixed'.

Nooo it's so many more clicks for me, @Jdforrester-WMF. Why don't you want
the sprint board for your sprint projects?

@Jdforrester-WMF before this regression, you could achieve the same by navigating to a project through the "Projects" link (as opposed to search). See
T89249 for reasoning why the Sprint-Extension has been kept separate from the main Phab UI.

I can't actually find any upstream changes that should have broken this.

Weird... it definitely used to work differently.

Thanks for looking into it @mmodell. Are there any next steps we can help with to resolve this issue?

FYI: This is something that is unique to the phabricator.wikimedia.org installation as I cannot reproduce this locally or on the test server at http://phab10.wmflabs.org. It therefore must be a configuration or WMF customization issue.

Niharika added a subscriber: Niharika.
Qgil removed a subscriber: Qgil.Dec 28 2015, 8:25 PM
Restricted Application added a subscriber: Luke081515. · View Herald TranscriptDec 28 2015, 8:25 PM

If more than one library is loaded with load-libraries, this would possibly be why this has happened on phabricator.wikimedia.org. PhutilSymbolLoader will only allow a single library to override default controller routes.

My instance definately only loading one library with load-libraries, which is sprint extension and I'm having this issue too. Most of my config is default.

I would really really like this to get fixed.

joshma added a subscriber: joshma.Feb 10 2016, 10:41 PM

this will be resolved by the new Project v3 workboards. Anticipated deployment to phabricator.wikimedia.org on 18.02.2016

The sprint board implementation has been removed in https://gerrit.wikimedia.org/r/#/c/270484/

Christopher closed this task as Resolved.Feb 18 2016, 9:27 AM
Christopher moved this task from Review to Done on the Phabricator-Sprint-Extension board.