Page MenuHomePhabricator

Incomplete but functioning template output results in broken Share a Fact images
Closed, ResolvedPublic

Description

This appears to apply to all versions of the app.

Event Timeline

dr0ptp4kt raised the priority of this task from to Needs Triage.
dr0ptp4kt updated the task description. (Show Details)
dr0ptp4kt moved this task to Needs Triage on the Wikipedia-iOS-App-Backlog board.
dr0ptp4kt added a subscriber: dr0ptp4kt.
Restricted Application added subscribers: StudiesWorld, Aklapper. · View Herald TranscriptDec 4 2015, 10:04 PM

View source of https://en.wikipedia.org/w/index.php?title=Logic_(rapper)&oldid=693775412

<p><span class="error" style="display:none">HIDDEN ERROR: Usage of "past names and nick names" is not recognized</span></p>
JMinor added a subscriber: JMinor.Dec 4 2015, 10:23 PM

Thanks for clarifying @dr0ptp4kt. The previous ticket made it seem like a product definition issue (should user pages allow share a fact?) rather than a bug. This looks more specifically like broken expectation.

JMinor triaged this task as Lowest priority.May 9 2016, 7:31 PM
JMinor added a project: iOS-app-Bugs.
JoeWalsh closed this task as Invalid.Feb 19 2019, 5:33 PM
JoeWalsh added a subscriber: JoeWalsh.

Unable to repro - the hidden error is no longer rendered by the old version of the page

JMinor changed the task status from Invalid to Resolved.Feb 19 2019, 9:22 PM

no longer reproducible

dr0ptp4kt added subscribers: MrStradivarius, TheDJ.EditedFeb 20 2019, 1:05 PM

Thanks. I'm not sure if something changed in a Scribunto module or somewhere in extension land, but it doesn't seem like it's really turning up on enwiki source, at least - there are some Village Pump discussions on this.

https://en.wikipedia.org/w/index.php?search=all%3A+insource%3A%22HIDDEN+ERROR%22+insource%3A%2F%22HIDDEN+ERROR%22%2F&title=Special%3ASearch&profile=advanced&fulltext=1&advancedSearch-current=%7B%22namespaces%22%3A%5B0%5D%7D&ns0=1

Closure of the ticket seems fine. For posterity's sake, @TheDJ @MrStradivarius do you happen to know if anything changed to prevent this sort of thing from happening again in the HTML output?

TheDJ added a comment.Feb 20 2019, 2:23 PM

This happens when a template usage triggers a template’s https://en.wikipedia.org/wiki/Module:Check_for_unknown_parameters checks.

As these tend to get cleaned up eventually, its likely this is indeed a temporary effect.

Okay, so based on @TheDJ feedback @JMinor it seems the issue may surface in fleeting edge case scenarios. Of course some would say making those errors visible is a feature, not a bug. Anyway, obviously this is your area for prioritization.