Provide RSS feeds for Special:Log
Open, LowestPublic

Description

Currently API provides (?action=feedwatchlist) me and other users an efficient way to be up on many things that happens in wikis. But for some purposes I need several other feeds: the ability to read logs (e.g., Special:Log/upload), user contributions (Special:Contributions/XXX) and linked recent changes (Special:Recentchangeslinked/XXX) in RSS format.


Version: unspecified
Severity: normal
See Also:
https://bugzilla.wikimedia.org/show_bug.cgi?id=24795

Details

Reference
bz10094
bzimport raised the priority of this task from to Lowest.
bzimport set Reference to bz10094.
bzimport added a subscriber: Unknown Object (MLST).
Kalan created this task.Jun 1 2007, 5:47 AM
vvv added a comment.Jun 3 2007, 12:21 PM

It seems to me that feed functions of MediaWiki is now not well-structured. Some of it is in main part of engine, some of it is in API. I think it's better to move Watchlist to main engine as it is done with page history.

Recentchanges is available as RSS and Atom, just visit the wiki and click the "RSS" or "Atom" link in the left navigation bar. I agree that these feeds should be retrievable through the API as well.

Special:Log and Special:Contributions each have API interfaces (action=query&list=logevents and action=query&list=usercontribs respectively), but no RSS feed as far as I know. A (temporary) solution could be to use these interfaces and convert the output to RSS yourself.

I'm not sure LE and UC will get RSS feeds, though, as few people will be interested in that.

cannon.danielc wrote:

Changing to LATER as there doesn't seem to be much desire for this feature at this time.

brianna.laugher wrote:

Why would few people be interested in logevents and usercontribs? Follow newly registered users, recently deleted pages, recently moved pages, recently protected pages, recently uploaded files...of course that is interesting!

Note http://toolserver.org/~daniel/WikiSense/Gallery.php could possibly be copied for the upload log feed (choose format RSS/atom).

[Removing RESOLVED LATER as discussed in http://lists.wikimedia.org/pipermail/wikitech-l/2012-November/064240.html . Reopening and setting priority to "Lowest". For future reference, please use either RESOLVED WONTFIX (for issues that will not be fixed), or simply set lowest priority. Thanks a lot!]

Just as a FYI, a link to Atom feed is now visible in the "Toolbox" section of the sidebar for Special:Contributions and Special:Recentchangeslinked, but we still don't have a feed link for Special:Log.

Re-titling bug to reflect comment 6.

(Unclear if this is really API's problem. Most special pages handle their own RSS feed.)

  • Bug 4182 has been marked as a duplicate of this bug. ***

Missing feeds for one of the components of history is IMHO a bug. It's surely inconsistent now that we have feeds for all the others.

Anomie moved this task from Unsorted to Needs Code on the MediaWiki-API board.Feb 20 2015, 8:21 PM

Could this be done generically somehow in the api - everything that could be a generator could also be output as an rss feed?

Anomie added a subscriber: Anomie.Feb 23 2015, 4:17 PM

Could this be done generically somehow in the api - everything that could be a generator could also be output as an rss feed?

That reminds me of T19872, although not as extreme. But it wouldn't help with API logevents, since that can't be a generator.

Sn1per claimed this task.Aug 22 2015, 8:22 PM
Sn1per added a subscriber: Sn1per.

Interesting...

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 22 2015, 8:22 PM
Sn1per removed Sn1per as the assignee of this task.Oct 27 2015, 10:54 PM