Page MenuHomePhabricator

Cannot find site jenkins_u3_mw
Closed, DuplicatePublic

Description

Every ContentTranslation unit test has this notice in the log, although it does not cause the test to fail. See https://integration.wikimedia.org/ci/job/mwext-qunit/8882/consoleText for example.

Notice: Cannot find site jenkins_u3_mw in sites table [Called from Wikibase\Client\WikibaseClient::newSiteGroup in /mnt/jenkins-workspace/workspace/mwext-qunit/src/extensions/Wikidata/extensions/Wikibase/client/includes/WikibaseClient.php at line 531] in /mnt/jenkins-workspace/workspace/mwext-qunit/src/includes/debug/MWDebug.php on line 300
Call Stack
# Time Memory Function Location
1 0.0020 231032 {main}( ) ../index.php:0
2 0.2433 4761080 MediaWiki->run( ) ../index.php:43
3 0.2434 4762224 MediaWiki->main( ) ../MediaWiki.php:474
4 0.6363 18845832 OutputPage->output( ) ../MediaWiki.php:707
5 0.6502 19584184 SkinTemplate->outputPage( ) ../OutputPage.php:2321
6 0.6502 19587720 SkinTemplate->prepareQuickTemplate( ) ../SkinTemplate.php:240
7 0.9600 26673120 Hooks::run( ) ../SkinTemplate.php:472
8 0.9601 26674048 call_user_func_array ( ) ../Hooks.php:195
9 0.9601 26674912 Wikibase\ClientHooks::onSkinTemplateOutputPageBeforeExec( ) ../Hooks.php:195
10 0.9703 26712616 Wikibase\Client\WikibaseClient->getLangLinkSiteGroup( ) ../WikibaseClient.hooks.php:301
11 0.9703 26712704 Wikibase\Client\WikibaseClient->getSiteGroup( ) ../WikibaseClient.php:510
12 0.9703 26712848 Wikibase\Client\WikibaseClient->newSiteGroup( ) ../WikibaseClient.php:549
13 1.0046 26890928 wfWarn( ) ../WikibaseClient.php:531
14 1.0046 26891208 MWDebug::warning( ) ../GlobalFunctions.php:1216
15 1.0057 26893016 MWDebug::sendMessage( ) ../MWDebug.php:155
16 1.0057 26893376 trigger_error ( ) ../MWDebug.php:300

This was spotted in T120349#1851758 but was not acted on.

T102854 claims a same or similar issue has been fixed.

Event Timeline

Nikerabbit raised the priority of this task from to Needs Triage.
Nikerabbit updated the task description. (Show Details)
Restricted Application added subscribers: StudiesWorld, Aklapper. · View Herald TranscriptDec 10 2015, 8:31 AM

Jenkins does not set up a sites config for the wiki. This is currently not generally required for a Mediawiki to work. The tests in Wikibase don't need this.

Maybe we should set a default entry up during update.php? That would also make it easier to set Wikibase with client wikis up.

Krinkle removed a subscriber: Krinkle.Feb 23 2016, 4:50 PM
Krinkle triaged this task as High priority.Mar 7 2016, 8:01 PM
Krinkle moved this task from Proposed to Review on the Wikidata-Sprint-2016-03-01 board.
Krinkle closed this task as Resolved.Mar 8 2016, 5:25 PM
Krinkle claimed this task.
Krinkle reopened this task as Open.Mar 9 2016, 8:56 PM

Still happening. Except now with the name mywiki and earlier (in update.php).

https://integration.wikimedia.org/ci/job/mediawiki-extensions-qunit/34327/consoleFull#console-section-1

00:00:38.563 PHP Notice:  Cannot find site mywiki in sites table [Called from Wikibase\Client\WikibaseClient::newSiteGroup in /mnt/jenkins-workspace/workspace/mediawiki-extensions-qunit/src/extensions/Wikidata/extensions/Wikibase/client/includes/WikibaseClient.php at line 611] in /mnt/jenkins-workspace/workspace/mediawiki-extensions-qunit/src/includes/debug/MWDebug.php on line 300
00:00:38.563 PHP Stack trace:
00:00:38.564 PHP   1. {main}() /mnt/jenkins-workspace/workspace/mediawiki-extensions-qunit/src/maintenance/update.php:0
00:00:38.564 PHP   2. require_once() /mnt/jenkins-workspace/workspace/mediawiki-extensions-qunit/src/maintenance/update.php:217
00:00:38.564 PHP   3. UpdateMediaWiki->execute() /mnt/jenkins-workspace/workspace/mediawiki-extensions-qunit/src/maintenance/doMaintenance.php:103
00:00:38.565 PHP   4. LoggedUpdateMaintenance->execute() /mnt/jenkins-workspace/workspace/mediawiki-extensions-qunit/src/maintenance/update.php:184
00:00:38.565 PHP   5. FlowCreateTemplates->doDBUpdates() /mnt/jenkins-workspace/workspace/mediawiki-extensions-qunit/src/maintenance/Maintenance.php:1438
00:00:38.565 PHP   6. FlowCreateTemplates->create() /mnt/jenkins-workspace/workspace/mediawiki-extensions-qunit/src/extensions/Flow/maintenance/FlowCreateTemplates.php:84
00:00:38.566 PHP   7. WikiPage->doEditContent() /mnt/jenkins-workspace/workspace/mediawiki-extensions-qunit/src/extensions/Flow/maintenance/FlowCreateTemplates.php:113
00:00:38.566 PHP   8. WikiPage->prepareContentForEdit() /mnt/jenkins-workspace/workspace/mediawiki-extensions-qunit/src/includes/page/WikiPage.php:1713
00:00:38.566 PHP   9. AbstractContent->getParserOutput() /mnt/jenkins-workspace/workspace/mediawiki-extensions-qunit/src/includes/page/WikiPage.php:2178
Krinkle removed Krinkle as the assignee of this task.Mar 9 2016, 9:00 PM
Bene added a subscriber: Bene.Mar 9 2016, 11:35 PM

Note that the previous error is still breaking REL1_26 as well.

Notice: Cannot find site jenkins_u1_mw in sites table [Called from Wikibase\Client\WikibaseClient::newSiteGroup in /mnt/jenkins-workspace/workspace/mediawiki-extensions-qunit/src/extensions/Wikidata/extensions/Wikibase/client/includes/WikibaseClient.php at line 528] in /mnt/jenkins-workspace/workspace/mediawiki-extensions-qunit/src/includes/debug/MWDebug.php on line
hashar added a subscriber: hashar.Dec 20 2016, 11:01 PM

That is most probably similar / a dupe of a more recent task T153729 going to reuse that one which is a bit more recent.

daniel added a comment.EditedDec 22 2016, 12:56 PM

Well yea. We no longer override the default side ID with "mywiki", so now it's the database name. Setting $wgWBClientSettings['siteGroup'] and/or $wgWBClientSettings['siteGlobalID'] should fix it.