Mails from MediaWiki seem to get (partially) lost
Closed, ResolvedPublic

Description

@Lydia_Pintscher and I individually noticed that emails that MediaWiki was supposed to send didn't reach us. The email accounts are hosted by different companies (gmail and 1and1), thus I suspect a problem within the Wikimedia infrastructure.

hoo created this task.Dec 10 2015, 2:46 PM
hoo updated the task description. (Show Details)
hoo raised the priority of this task from to Needs Triage.
hoo added projects: Operations, Mail.
hoo added subscribers: hoo, Lydia_Pintscher.
Restricted Application added subscribers: StudiesWorld, Aklapper. · View Herald TranscriptDec 10 2015, 2:46 PM

To be specific I do miss several notification emails for changes on meta, wikidata and dewp. I do receive some notification emails from these wikis but apparently not all.

Dzahn added a subscriber: Dzahn.Dec 10 2015, 9:10 PM

please add more details: which email addresses, around what time should they have been sent, the mail subject if you know it

without that we don't really have anything to check the logs for

Dzahn added a comment.EditedDec 12 2015, 2:01 AM

@Lydia_Pintscher

i checked our mail logs, and i can confirm there are 4 emails that have:

  • been sent to lydia.pintscher@wikimedia.de
  • on December 10
  • origin is wikidata wiki

all 4 ended with the status "Completed" and have been delivered to mxlb.ispgateway.de

Dzahn added a comment.Dec 12 2015, 2:08 AM

@hoo i can't confirm an issue on our side. i also see mail delivered to you on that day, but @wikimedia.de and both are H=mxlb.ispgateway.de which other account (gmail vs. 1and1) were you talking about?

hoo added a comment.Dec 12 2015, 3:16 AM

@hoo i can't confirm an issue on our side. i also see mail delivered to you on that day, but @wikimedia.de and both are H=mxlb.ispgateway.de which other account (gmail vs. 1and1) were you talking about?

Ugh, seems I got confused here. I actually received all emails I should have received.

Dzahn added a comment.Dec 14 2015, 6:50 PM

Alright, so @hoo you think we can close it as invalid then?

Ottomata triaged this task as Low priority.Dec 14 2015, 8:05 PM
Ottomata assigned this task to Dzahn.
Ottomata set Security to None.
Ottomata added a subscriber: Ottomata.

@Dzahn, since you are in touch about this, I am assigning to you. Feel free to change status as you see fit.

Dzahn closed this task as Invalid.Dec 14 2015, 10:03 PM

@hoo @Lydia_Pintscher if you disagree please reopen the ticket again. thanks

Lydia_Pintscher reopened this task as Open.Dec 15 2015, 11:07 AM

I am still not getting emails for some edits. This one for example should have triggered an email to me but I did not receive it: https://www.wikidata.org/w/index.php?title=Wikidata:Requests_for_comment/Improve_bot_policy_for_data_import_and_data_modification&diff=283379690&oldid=282545988 Some other edit notifications from the same wiki on the same account do arrive fine.
I did check my spam folder.

Is there anything else I can provide?

Dzahn added a comment.Dec 16 2015, 1:32 AM

@Lydia_Pintscher hmm, any similarity between the ones that don't work vs. the ones that work? Like for example these are all in the Wikidata: namespace but maybe others are not? Do you see any pattern like that at all? You are also sure these are all on your watchlist?

Another one: https://www.wikidata.org/w/index.php?title=Wikidata:Showcase_items&diff=283781453&oldid=278234143

I can't really make out a pattern. They are mostly in the project namespace but that mught just be due to me watching mostly project namespace pages with that account and not caring about it content pages too much (I handle these with my private account).
They are on my watchlist.
I notice the issues because I usually go through my email notifications and then to the watchlist page on-wiki. I open all my edit notification emails and click the link to see all changes since the edit has been made. So there should not be any unwatched pages besides the ones where the first un-checked edit was a minor edit.

(It also doesn't seem restricted to Wikidata. Similar things seem to happen with dewp and mediawiki at least. Though I have considerably fewer pages to watch there so not as obvious.)

Could i have another pair of eyes here please? I don't really see a pattern here, unsure how to go ahead with debugging. I apologize for the delay.

Dzahn removed Dzahn as the assignee of this task.Feb 19 2016, 10:12 PM
Dzahn raised the priority of this task from Low to Normal.

Could i have another pair of eyes here please? I don't really see a pattern here

Wondering if it's another case of those items I listed in https://lists.wikimedia.org/pipermail/engineering/2016-June/000211.html

@hoo, @Lydia_Pintscher : Still an issue, 18 months later? Or should this task be closed?

hoo added a comment.Wed, Dec 27, 11:33 AM

@hoo, @Lydia_Pintscher : Still an issue, 18 months later? Or should this task be closed?

I haven't had any (apparent) issue any time recently. So closing this is fine with me.

Lydia_Pintscher closed this task as Resolved.Wed, Dec 27, 11:36 AM
Lydia_Pintscher claimed this task.

Yeah it seems ok now.