Page MenuHomePhabricator

Goal: Translations strategy
Closed, ResolvedPublic

Description

The Wikimedia Foundation is constantly failing to communicate with the communities as we'd want to due to the amount of text and relative lack of volunteer translators. On the one hand, this is deeply problematic, as we're ineffective when it comes to reaching out in most languages that aren't English. On the other hand, it's possible we don't want editors to focus on working on our communication instead of contributing content to the projects,

Come up with a strategy to try to address the lack of volunteer translators.

Some sort of strategy to act upon in the coming months and refine thereafter.

Related Objects

StatusAssignedTask
DuplicateQgil
ResolvedQgil
ResolvedQgil
OpenNone
OpenNone
OpenAreefa
ResolvedJohan
ResolvedJohan
ResolvedTrizek-WMF
OpenNone
ResolvedTrizek-WMF
ResolvedTrizek-WMF
ResolvedTrizek-WMF
Resolvedjmatazzoni
Resolvedjmatazzoni
Resolvedjmatazzoni
ResolvedTrizek-WMF
ResolvedTrizek-WMF
ResolvedMtDu
OpenNone

Event Timeline

Johan created this task.Dec 11 2015, 8:41 AM
Johan updated the task description. (Show Details)
Johan raised the priority of this task from to Needs Triage.
Johan claimed this task.
Johan shifted this object from the S1 Public space to the Restricted Space space.
Johan changed the visibility from "Public (No Login Required)" to "acl*communityrelations_policy_admins (Project)".
Johan added a subscriber: Johan.
Johan triaged this task as Normal priority.Dec 11 2015, 9:54 AM
Johan set Security to None.
Johan shifted this object from the Restricted Space space to the S1 Public space.Jan 25 2016, 3:04 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 25 2016, 3:04 AM
Johan changed the visibility from "acl*communityrelations_policy_admins (Project)" to "Public (No Login Required)".Jan 25 2016, 3:06 AM

I've added T121500: Unify product documentation for users to make it easier to share, translate and edit as a blocked task. Actually, this task is not really blocked by your goal, Johan, but I'll probably need to work with you closely concerning the future of translations.

Johan moved this task from Backlog to Doing on the Liaisons-February-2016 board.Feb 1 2016, 9:16 PM
Johan added a subscriber: egalvezwmf.EditedFeb 23 2016, 6:01 PM

I had a meeting with @egalvezwmf earlier, who had a few questions he wanted answered in the process.

  • How do we get more translators (the question already at the core of this task, of course).
  • Do translators get enough recognition? (Today, it's very much up to the person who's asking for help.) Do they want more? (Because if they do, they certainly recognize it. Non-content translation is rarely as visible as e.g. photographing for Commons, writing articles or even being a good vandal fighter.)
  • How many have used the translation tool? Edward will be looking into this.
  • How much time do they have? Do we have more translation requests than we have translator time? (The suspicion behind this task.)
  • Why are they motivated to translate?

Thanks for posting @Johan!

Johan added a subscriber: Qgil.EditedFeb 26 2016, 1:10 PM

For transparency, trying to summarize a couple of discussions I've had lately here:

@Qgil wants this to be connected to product development process. This makes sense, for part of a good chunk of it.

We have several aspects of translation:

  • Content translation on content wikis (e.g. Wikipedia articles from Swedish to German). This is not really related to this task.
  • Translation of Wikimedia products. This is very much potentially related to the product development process, and reasonably time-sensitive: we very much prefer everything to be translated into the language of a wiki before it's deployed there.
  • Translation of movement documentation, making sure that important information on Meta exists in more languages than English. This is not a time-sensitive task, and we honestly can't expect most pages to ever get any larger number of translations. This is less related to the product development process.
  • Messages to the communities, usually from the WMF to be posted on e.g. Village Pumps. This is very time-sensitive, as the translation must be done before the message is sent out, and the message itself is often relevant only for a shorter period of time (but could be very important those days or weeks). This is occasionally related to the product development process, but not necessarily so.

Also, @Trizek-WMF is looking into if Special:TranslatorSignup is a good way of facilitating translations, how well it is actually working.

Elitre added a subscriber: Elitre.Feb 26 2016, 1:23 PM

Yeah, I was about to ask whether someone considered expanding/tweaking Special:TranslatorSignup to suit particular needs.

Johan renamed this task from Goal: Translations strategy to Goal: Translations strategy.Feb 26 2016, 3:30 PM
Johan added a project: Liaisons-March-2016.
Johan moved this task from Backlog to Do now on the User-Johan board.Feb 29 2016, 1:03 PM
Johan added a comment.Mar 7 2016, 4:42 PM

See also T129088 about glossaries.

Johan added a comment.Mar 8 2016, 11:56 AM

It could be, but not as it's written. The completion criterion for that task is to create a translation strategy of some sort. One could imagine putting everything regarding translation strategy into it, but then it's never really going to be closed.

@Johan - that list looks almost good to me. I would ask to add surveys to the list - its an important aspect of translation that we need support with. Also - translation of "movement documentation" is actually important often (e.g. Strategy work, board elections, etc.). I would change that bullet to *some* pages are time-sensitive, but many are not. Thanks!

Johan added a comment.Apr 2 2016, 7:26 AM

Some sort of strategy to act upon in the coming months and refine thereafter.

Johan closed this task as Resolved.Apr 2 2016, 7:27 AM
Johan moved this task from Do now to Archive on the User-Johan board.Apr 2 2016, 8:29 AM
Qgil added a comment.Apr 2 2016, 9:40 AM

I think that even in its more bare state, a strategy should define what are the current problems to be solved, and what are the goals to be achieved, and how. The current wiki page has key untold assumptions, the problem is not stated, the actions are not clear...

Also, have you got any involvement of actual translators in this strategy?

Don't get me wrong, it is a good exercise and it is going in a good direction, but I am not sure this can be considered a reliable phase to "act and refine" in T128790.

Johan added a comment.EditedApr 2 2016, 12:38 PM

OK, it's true that the "done" phase of this is not actually represented on-wiki, but rather a reflection of conversations. I'll re-open the task and close it again in a week or so once that is fixed.

Johan reopened this task as Open.Apr 2 2016, 12:38 PM
Qgil added a comment.May 3 2016, 6:31 AM

For what is worth: T60429: Translation pages: display outdated translations as such, without removing them.

I believe this task will have a positive impact on the routines of volunteer translators, and the pressure they get to translate updated texts.

Qgil updated the task description. (Show Details)May 9 2016, 12:21 PM
Johan added a comment.May 9 2016, 2:06 PM

Current status: I'm pinging translators, both within the movement and people who work with translations outside the Wikimedia context, to get feedback on the strategy. Anyone is welcome to comment on the talk page, of course.

Johan closed this task as Resolved.Jun 17 2016, 11:42 AM
Qgil awarded a token.Jun 20 2016, 9:13 AM