Page MenuHomePhabricator

Download as PDF via rdf2latex causes several rendering problems
Closed, InvalidPublic

Description

A PDF file created by bookcmd=render_article&writer=rdf2latex contains a lot of errors.
Overview

  1. Because pages are divided by 2 columns, formulas are overwritten by text or cut off.
  2. Graphics aren't positioned where they should.
  3. Templates aren't interpreted correctly.
  4. <math> contents aren't rendered correctly.

Details
See the related items in appendix 2.

  1. Formulas should be indented by <p style="margin-left:4.5em;"> but aren't. See the formula template.
  2. The next graphic should be positioned before the following text paragraph.
  3. This graphic element is part of a template containing the next paragraph. The graphic should be positioned left to the text (not above).
  4. Formulas that are too wide go beyond the text area and are cut off (in column 2) or overwritten by other text (in column 1). That's a direct effect caused by the two-columns text area by default. It's urgently requested to ask the user whether he wants one or two columns.
  5. Wikitables are not shown (as well as part of a template's content or directly in the wiki site).
  6. \text parts inside a <math> formula that contain more than one word aren't shown in the correct sequence: "mit dem Winkel" is replaced by "Winkel dem mit", e.g.
  7. Bold text inside a template is sometimes rendered as light text.
  8. Italic text inside a template is sometimes rendered as straight text.
  9. One template isn't shown at all. Therefore the reader cannot see where a specific exercise or solution starts and ends.

Multiple occurrencies of the same fault aren't marked normally. (In appendix 2 there are additional faults but not related to the MediaWiki problems.)

How to check the problems

  1. Use MathML in user preferences / appearance.
  2. de-Wikibooks chapter "Komplexe_Zahlen/_Darstellungsformen" - the requested page (Internet Explorer 11 isn't able to show correct formulas using MathML)
  3. Use Print/Preview/Print of the browser (here: Firefox 42.0) - every part of the page is printed correctly (IE isn't able to show any formulas)
  4. Use Special:Book render_article rdf2latex and store the created pdf file.
  5. Appendix 1 F3079535 is the created pdf file without any change.
  6. Appendix 2 F3079554 shows the errors listed above (and contains some more errors caused by convertion to OpenOfficeGraph odg).

Event Timeline

Juetho created this task.Dec 13 2015, 4:45 PM
Juetho updated the task description. (Show Details)
Juetho raised the priority of this task from to High.
Juetho added a project: Collection.
Juetho added a subscriber: Juetho.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 13 2015, 4:45 PM

Hi @Juetho, thanks for taking the time to report this!

Please include only one problem per report. See https://www.mediawiki.org/wiki/How_to_report_a_bug .
For example,

Wikitables are not shown (as well as part of a template's content or directly in the wiki site).

is already logged as meta-bug T73808.

Hi @Aklapper, thank you for the hint to wikitables. I see my report as one great problem concerning PDF rendering. I'll wait for fixing it. At the moment, the PDF feature is partly useless.

Aklapper raised the priority of this task from High to Needs Triage.Dec 14 2015, 10:28 AM

(Resetting "priority" value to default.)

I see my report as one great problem concerning PDF rendering. I'll wait for fixing it.

There are several different technical problems intermingled in one report. Hence it's impossible for both developers and reporters to properly track and document any progress of each issue listed in this report and this report might end up as being ignored due to not being well-structured. :(

Restricted Application added a subscriber: StudiesWorld. · View Herald TranscriptDec 14 2015, 10:28 AM
Juetho added a comment.EditedDec 14 2015, 10:42 AM

Now there are separate tasks for the detailed problems:

  1. detail 1 - formula indention see T121498
  2. detail 2 - position 1 of graphics see T121501
  3. detail 3 - position 2 of graphics see T121503
  4. detail 4 - formulas in two-column text area see T121497
  5. detail 6 - text in a formula see T121504
  6. detail 7/8 - wrong format by a template see T121506
  7. detail 9 - template omitted see T121507

@Aklapper: The priority meant that the PDF is partly useless.

Juetho closed this task as Invalid.
Juetho set Security to None.

Thank you for filing dedicated separate tasks.