Page MenuHomePhabricator

Following links on iOS require two taps (iPad & iPhone, Safari & Chrome)
Closed, DeclinedPublic

Description

On iPad (iOS 9) and using the desktop version of the wikipedia, the first time a page is loaded, a link can only be followed if the link is tapped twice. On the first tap, the link becomes underlined and on the second, the link is followed.

Steps to reproduce:

  1. Use desktop version of wikipedia (on an iPad).
  2. Load homepage.
  3. Tap any link (becomes undelined).
  4. Tap again (goes to page).

Expected behavior: the link is followed on the first tap.

I've tested this on two different iPads with the same result.

Event Timeline

leonelmartins raised the priority of this task from to Needs Triage.
leonelmartins updated the task description. (Show Details)
leonelmartins added a subscriber: leonelmartins.
Restricted Application added subscribers: StudiesWorld, Aklapper. · View Herald TranscriptDec 15 2015, 11:11 PM

Hi @leonelmartins, thanks for taking the time to report this!

Which browser and browser version is this about?

It's Safari, that ships with iOS 9.2 (but this has been happening with earlier versions too).

Here's the User-Agent:

Mozilla/5.0 (iPad; CPU OS 9_2 like Mac OS X) AppleWebKit/601.1.46 (KHTML, like Gecko) Version/9.0 Mobile/13C75 Safari/601.1

Pengo renamed this task from Following links on iPad require two taps to Following links on iOS require two taps (iPad & iPhone, Safari & Chrome) .Feb 10 2016, 9:45 PM
Pengo triaged this task as High priority.
Pengo added a comment.EditedFeb 10 2016, 9:52 PM

This is not a minor UX issue.

Occurs not just on Safari, but also Chrome. Not just iPad but also iOS.

Doesn't just affect links within the article, but also other navigation links like tapping tabs (e.g. "history"), the top nav like "log in", check boxes like "Keep me logged in", And other UI elements like the "Save page" button.

It causes the entire site to appear unresponsive or broken to users who choose or need to use the desktop version of Wikipedia from their mobile device.

Is anyone working on fixing this?

Looks like iOS 9.3 fixed this issue!

https://css-tricks.com/annoying-mobile-double-tap-link-issue/

It's a general issue that existed with iOS 9. It's by design and I don't think this changed in iOS 9.3 or even iOS 10. However, the issue only happens if the website changes the link layout on :hover. In general, Wikipedia doesn't do this. The only thing that changes on-hover is the text being underlined, for which no extra layout or space reservation is required.

It's possible an extension or site script was temporarily making a layout change. Either way, this will have been resolved by now. Closing it as such. Please do re-open if you find this again. Thanks @leonelmartins !

Krinkle closed this task as Declined.Jun 23 2017, 1:16 AM
Krinkle edited projects, added MediaWiki-Interface; removed MediaWiki-General.