[betalabs] 'Uncaught TypeError: Cannot read property 'commandRegistry' of null' for posting new topic
Closed, ResolvedPublic

Description

Previous fixes for 'Uncaught TypeError: Cannot read property 'commandRegistry' of null' are reported in T108876: [betalabs] Uncaught TypeError: Cannot read property 'commandRegistry' of null and T109750: [betalabs] 'Cancel' Summarize gives "Cannot read property 'commandRegistry'"

The issue seems to be specific to exact steps that described below - Reply and then try to post a new topic(not for two replies or two new topics in a row).

  1. Click on Reply - make sure that VE mode is selected.
  2. Enter some text and click 'Reply' to save.
  3. Click on 'Start a new topic' - make sure that the CE is in VE mode
  4. As soon as you click in CE field - the following error is displayed:
Uncaught TypeError: Cannot read property 'commandRegistry' of null
ve.ui.Tool.getCommand
ve.ui.Tool.onUpdateState
ve.ui.AnnotationTool.onUpdateState
oo.EventEmitter.emit
ve.ui.Toolbar.updateToolState
ve.ui.Toolbar.onContextChange
oo.EventEmitter.emit
ve.dm.Surface.stopQueueingContextChanges
ve.dm.Surface.changeInternal
ve.dm.Surface.change
ve.ce.Surface.changeModel
ve.ce.Surface.handleObservedChanges
ve.ce.SurfaceObserver.pollOnceInternal
ve.ce.SurfaceObserver.pollOnceSelection
ve.ce.Surface.onDocumentSelectionChange
jQuery.event.dispatch
elemData.handle
Etonkovidova updated the task description. (Show Details)
Etonkovidova raised the priority of this task from to Needs Triage.
Etonkovidova added a subscriber: Etonkovidova.
Restricted Application added subscribers: StudiesWorld, Aklapper. · View Herald TranscriptDec 16 2015, 2:21 AM
Etonkovidova renamed this task from [betalabs] Uncaught TypeError: Cannot read property 'commandRegistry' of null for posting new topic to [betalabs] 'Uncaught TypeError: Cannot read property 'commandRegistry' of null' for posting new topic.Dec 16 2015, 2:22 AM
Etonkovidova updated the task description. (Show Details)
Etonkovidova set Security to None.

I can't reproduce with the steps you gave, but this bug is a month old. Is this still happening?

jmatazzoni closed this task as Resolved.Apr 25 2016, 10:25 PM

Re-checked in betalabs -no errors in Console are displayed.