Related articles are on top of article after editing a page with the visual editor
Closed, ResolvedPublic

Description

Tested twice on frwp.

[edit]
What I did:

  1. I edit this article with the visual editor
  2. I saved my edits, Related articles are on top
  3. I refresh the page, Related articles are at the bottom, where they are supposed to be.
Trizek-WMF added a project: RelatedArticles.
Trizek-WMF added subscribers: Trizek-WMF, Moushira.
Restricted Application added subscribers: StudiesWorld, Aklapper. · View Herald TranscriptDec 16 2015, 4:25 PM

This was fixed in T120443 so am not sure what's happening here. Will have to check if that patch made it out..

Jdlrobson removed Jdlrobson as the assignee of this task.Dec 16 2015, 4:43 PM
Jdlrobson added a subscriber: Jdlrobson.
KLans_WMF triaged this task as "High" priority.Dec 16 2015, 5:55 PM
Trizek-WMF edited the task description. (Show Details)Dec 17 2015, 9:42 AM

I can't replicate this. I suspect that this might be a race condition, where the edit button is clicked whilst related articles is still loading.. is this possible?

I can't replicate this. I suspect that this might be a race condition, where the edit button is clicked whilst related articles is still loading.. is this possible?

On the two tests I've (incidentally) conducted, I was reading the articles. I've started editing it a moment after they were loaded.

To be sure, I've retried it today, and I can't reproduce it anymore. I've tried what you suggest, by clicking edit while the page was still loading, and Related article were effectively on top.

Thanks a bunch @ Trizek-WMF
It does sound like this is what happening. We'll get to the bottom of this! :)

Just a note that I've seen this several times in the past week or so.

phuedx changed the title from "Related article are on top of article after editing a page with the visual editor" to "Related articles are on top of article after editing a page with the visual editor".Jan 18 2016, 5:25 PM

Just came here to report the exact same bug. I just made a VE edit in en.wp and the related articles then came up appearing on top. This was the edit - https://en.wikipedia.org/w/index.php?title=Anu_Singh&type=revision&diff=700491912&oldid=686000746 See attached screenshot for how it appeared on my screen.

Using Chrome (47), Mac OS 10.10.2.

Jdlrobson lowered the priority of this task from "High" to "Normal".Jan 28 2016, 10:44 PM

This should be fixed in latest master but I've added it to next sprint to check.

Tested this morning:

Jdlrobson added a comment.EditedJan 29 2016, 3:37 PM

@Trizek-WMF it's fixed in latest master. It hasn't been deployed to any of the wikipedias yet.

Gonna be deployed this week?

(And thank you for your edit on your message :))

@Trizek-WMF it's on the train so will start trickling out next week. We could swat deploy it if you figure this is super urgent but given it's a beta feature I think it's okay for us to wait! ;)

I don't think it is urgent. People know this bug is going to be fixed.

That's was just me who believed it was already fixed! :D

phuedx added a subscriber: phuedx.Feb 3 2016, 11:20 AM

@Jdlrobson: For posterity, which commit(s) fixed this bug?

@phuedx the redesign in T122030 took the related articles out of the content area so it is no longer conflicting with VisualEditor, so those design changes as a side effect fixed the bug.

phuedx added a comment.Feb 4 2016, 8:58 PM

Confirmed fixed on testwiki.

phuedx closed this task as "Resolved".Feb 4 2016, 8:58 PM
phuedx claimed this task.