Some Squids seem to be serving stale pages
Closed, DeclinedPublic

Description

Author: mark

Description:
On Windows XP SP2:

on http://http://en.wikipedia.org/wiki/Network_Marketing

The first sentence of the "Criticism of MLM" section in Firefox 2.0.0.4 reads:
"The MLM model does not guarantee the success of any individual involved in this model. The success will depend primarily on amount of work done by the individual and is not a good model for mediocre persons."

In Internet Explorer 6.0.2900.2180, this sentence is completely missing. It does not even appear in the source code.


Version: unspecified
Severity: normal
URL: http://http://en.wikipedia.org/wiki/Network_Marketing

bzimport added a subscriber: wikibugs-l.
bzimport set Reference to bz10173.
bzimport created this task.Via LegacyJun 6 2007, 6:42 PM
bzimport added a comment.Via ConduitJun 6 2007, 8:51 PM

matthew.britton wrote:

Works for me. Most likely, Internet Explorer has cached an older version of the page; try clearing your browser cache and see if the problem persists.

bzimport added a comment.Via ConduitJun 6 2007, 8:53 PM

matthew.britton wrote:

Actually, I've got that the wrong way round; since the text is no longer in the article, it's Firefox that has cached an older version.

bzimport added a comment.Via ConduitJun 6 2007, 9:00 PM

mark wrote:

I had definitely never visited this page before. I tried it on another platform and it did the same.

bzimport added a comment.Via ConduitJun 6 2007, 9:12 PM

ayg wrote:

Can't reproduce.

Platonides added a comment.Via ConduitJun 6 2007, 9:18 PM

If accessing (with Firefox) http://en.wikipedia.org/wiki/Network_Marketing which is a redirect to [[w:Multi-level marketing]], i get "page last modified 23:03, 4 June 2007", but http://en.wikipedia.org/wiki/Multi-level_marketing "last modified 20:38, 6 June 2007".

GET /wiki/Network_Marketing HTTP/1.1
....
If-Modified-Since: Mon, 04 Jun 2007 23:03:33 GMT

HTTP/1.0 304 Not Modified
Date: Tue, 05 Jun 2007 00:16:10 GMT
Content-Type: text/html; charset=utf-8
Last-Modified: Mon, 04 Jun 2007 23:03:33 GMT
Age: 161466
X-Cache: HIT from knsq1.knams.wikimedia.org
X-Cache-Lookup: HIT from knsq1.knams.wikimedia.org:3128
X-Cache: MISS from knsq5.knams.wikimedia.org
X-Cache-Lookup: MISS from knsq5.knams.wikimedia.org:80
Via: 1.0 knsq1.knams.wikimedia.org:3128 (squid/2.6.STABLE12), 1.0 knsq5.knams.wikimedia.org:80 (squid/2.6.STABLE12)
Connection: keep-alive

After a Ctrl+F5 the right version is provided and:

HTTP/1.0 304 Not Modified
Date: Wed, 06 Jun 2007 21:14:31 GMT
Content-Type: text/html; charset=utf-8
Last-Modified: Wed, 06 Jun 2007 20:38:38 GMT
Age: 68
X-Cache: HIT from knsq1.knams.wikimedia.org
X-Cache-Lookup: HIT from knsq1.knams.wikimedia.org:3128
X-Cache: MISS from knsq7.knams.wikimedia.org
X-Cache-Lookup: MISS from knsq7.knams.wikimedia.org:80
Via: 1.0 knsq1.knams.wikimedia.org:3128 (squid/2.6.STABLE12), 1.0 knsq7.knams.wikimedia.org:80 (squid/2.6.STABLE12)
Connection: keep-alive

bzimport added a comment.Via ConduitOct 9 2007, 5:36 AM

mikelehen wrote:

I'm seeing this problem as well. In my case, when I requested the article http://en.wikipedia.org/wiki/Zorb (which redirects to Zorbing), the first sentence I saw was "Zorbing is a recreational activity developed in the 1990s ..." which is over 24 hours old.

I'm using IE 7 on Windows XP SP2. I cleared my browser cache and was still able to reproduce the problem. Here's the HTTP exchange:

GET /wiki/Zorb HTTP/1.1
Accept: image/gif, image/x-xbitmap, image/jpeg, image/pjpeg, application/x-shockwave-flash, */*
Accept-Language: en-us
UA-CPU: x86
Accept-Encoding: gzip, deflate
User-Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 1.1.4322; .NET CLR 2.0.50727)
Host: en.wikipedia.org
Connection: Keep-Alive

HTTP/1.0 200 OK
Date: Sun, 07 Oct 2007 15:50:15 GMT
Server: Apache
X-Powered-By: PHP/5.1.4
Content-Language: en
Vary: Accept-Encoding,Cookie
Cache-Control: private, s-maxage=0, max-age=0, must-revalidate
Last-Modified: Sat, 06 Oct 2007 18:19:07 GMT
Content-Encoding: gzip
Content-Length: 7686
Content-Type: text/html; charset=utf-8
Age: 131313
X-Cache: HIT from sq34.wikimedia.org
X-Cache-Lookup: HIT from sq34.wikimedia.org:3128
X-Cache: MISS from sq34.wikimedia.org
X-Cache-Lookup: MISS from sq34.wikimedia.org:80
Via: 1.0 sq34.wikimedia.org:3128 (squid/2.6.STABLE13), 1.0 sq34.wikimedia.org:80 (squid/2.6.STABLE13)
Connection: keep-alive

I'm not sure if it's relevant, but the "Date:" in the response isn't even correct. It's a couple days old.

I did a Ctrl+F5 and the problem was fixed. Here's the exchange (Ctrl+F5 seems to add "Cache-Control: no-cache" to the request):

GET /wiki/Zorb HTTP/1.1
Accept: */*
Accept-Language: en-us
UA-CPU: x86
Accept-Encoding: gzip, deflate
User-Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 1.1.4322; .NET CLR 2.0.50727)
Host: en.wikipedia.org
Connection: Keep-Alive
Cache-Control: no-cache

HTTP/1.0 200 OK
Date: Tue, 09 Oct 2007 05:22:22 GMT
Server: Apache
X-Powered-By: PHP/5.2.1
Content-Language: en
Vary: Accept-Encoding,Cookie
Cache-Control: private, s-maxage=0, max-age=0, must-revalidate
Last-Modified: Tue, 09 Oct 2007 05:16:50 GMT
Content-Encoding: gzip
Content-Length: 7591
Content-Type: text/html; charset=utf-8
X-Cache: MISS from sq34.wikimedia.org
X-Cache-Lookup: HIT from sq34.wikimedia.org:3128
X-Cache: MISS from sq33.wikimedia.org
X-Cache-Lookup: MISS from sq33.wikimedia.org:80
Via: 1.0 sq34.wikimedia.org:3128 (squid/2.6.STABLE13), 1.0 sq33.wikimedia.org:80 (squid/2.6.STABLE13)
Connection: keep-alive

And now the "Date:" is correct and "Last-Modified" seems to represent the last edit, and everything is good...

It looks like every time the "Zorbing" page gets updated, I keep getting stale results at http://en.wikipedia.org/wiki/Zorb (which redirects to "Zorbing") until I press Ctrl+F5.

bzimport added a comment.Via ConduitOct 9 2007, 5:42 AM

mikelehen wrote:

Oh. Also note that http://en.wikipedia.org/wiki/Zorbing always gives me the latest version of the page, even when http://en.wikipedia.org/wiki/Zorb doesn't.

Platonides added a comment.Via ConduitOct 9 2007, 1:05 PM

When you edit a page, the server send a message to the squids asking them to discard their copy. Seems it's not being done for pages redirected to it.

TheDJ added a comment.Via ConduitDec 5 2011, 3:04 PM

See also bug 24575 ???

Matanya added a comment.Via ConduitJul 30 2012, 7:51 PM

wasn't updated for a long time and I failed to reproduce. works for me.

bzimport added a comment.Via ConduitJul 31 2012, 4:11 PM

mr_moogle.geo wrote:

Did you edit the page first? It typically happens after an edit. And it also has seemed to be different if logged in as registered user.

Bawolff added a comment.Via ConduitJul 31 2012, 7:01 PM

(In reply to comment #11)

Did you edit the page first? It typically happens after an edit.

Well that is typically the point where pages become stale.

And it also
has seemed to be different if logged in as registered user.

Well given this bug is about squid cache, which is totally bypassed by logged in users, this is to be expected.


Ost316: Has this been specificly happening to you in the near term (like in the last month), otherwise I think this bug should be closed. (In all probability, since 2007 we have probably had multiple instances of squid purging being broken then fixed again)

bzimport added a comment.Via ConduitAug 7 2012, 5:37 PM

mr_moogle.geo wrote:

I don't often browse or edit logged out, but it definitely has been since 2009 that I last saw the error. And it was more than just a few minutes old. It seems to be a bug that isn't always easily repeatable. The last reference I can remember was in 2011: http://en.wikipedia.org/wiki/Wikipedia_talk:WikiProject_Video_games/Archive_87#The_shortcut_displays_an_older_version_of_this_page Perhaps it has been fixed since then, but it would be nice to have more of a reason than just it not being repeated.

Bawolff added a comment.Via ConduitAug 7 2012, 5:40 PM

Well squid purges are handled via UDP, which is an unreliable protocol. No checks are done to see that the purge packet actually arrived to the destination, so its entirely possible for pages to easily start to fail to purge if Wikimedia's internal network gets overloaded.

MZMcBride added a comment.Via ConduitMar 23 2014, 11:28 PM

Is there anything actionable here?

Bawolff added a comment.Via ConduitMar 24 2014, 1:35 AM

We have since improved monitoring of purging, its quite possible this no longer happening (they still use udp which is unreliable, but packet loss is generally quite low from what i understand.). Anyhow if people are still experiancing this speak up.

Ive heard some people talk about changing the udp to something fancier, which prevent packet loss being an issue. I think there was a discussion on an rfc somewhere. Anyhow a lot of that is beyond my knowladge

jeremyb-phone added a project: Varnish.Via WebDec 29 2014, 3:30 PM
jeremyb-phone added a subscriber: jeremyb-phone.
jeremyb-phone closed this task as "Declined".Via WebDec 29 2014, 3:35 PM
jeremyb-phone claimed this task.

if anyone sees something relevant still then file a new bug. no recent claims here that anything is currently broken. (and it's hard to overstate how much has changed since days of squid)

Add Comment