Page MenuHomePhabricator

Upgrade librsvg to 2.22.2
Closed, ResolvedPublic

Description

Author: andrewpmk

Description:
Librsvg, Wikimedia's SVG renderer should be upgraded to version 2.16.0 to fix rendering bugs that have been fixed in the most recent version. The following image does not render properly in the version that is currently installed (2.14.0, I believe): http://upload.wikimedia.org/wikipedia/en/archive/8/8e//20070609175619%21Building_and_ship_comparison.svg. It works fine in Firefox, Inkscape and librsvg 2.16.0. (To test librsvg, install the package that contains rsvg - librsvg2-bin in Ubuntu and presumably Debian - and run rsvg-view.)

Details

Reference
bz10207

Event Timeline

bzimport raised the priority of this task from to Normal.Nov 21 2014, 9:54 PM
bzimport set Reference to bz10207.
bzimport added a subscriber: Unknown Object (MLST).
bzimport created this task.Jun 9 2007, 7:19 PM

robchur wrote:

Bumping version in response to bug 5235. Not sure if the bug tracker is best for requesting this sort of thing; one would assume such upgrades could be performed on a regular basis as part of normal operating procedures.

ayg wrote:

Removing explicit version number in summary, which seems to get quickly outdated. The current version is apparently 2.22.

brion added a comment.Aug 11 2008, 5:08 PM
  • Bug 15115 has been marked as a duplicate of this bug. ***

Done. Will continue to need periodic manual recompilation because we're using a custom package.

JoKalliauer reopened this task as Open.Jul 17 2018, 8:06 PM
JoKalliauer updated the task description. (Show Details)
JoKalliauer added subscribers: kaldari, Aklapper, Glrx and 2 others.
Reedy closed this task as Resolved.Jul 17 2018, 8:08 PM
Reedy claimed this task.
Reedy added a subscriber: Reedy.

@JoKalliauer please open a new bug

Reedy updated the task description. (Show Details)Jul 17 2018, 8:09 PM
Reedy removed a project: Shell.
Reedy removed a subscriber: wikibugs-l-list.

@JoKalliauer: Please don't reopen ancient bugs; see T193352#4166886 for the actual problem to solve first.

Aklapper renamed this task from Upgrade librsvg to Upgrade librsvg to 2.22.2.Jul 17 2018, 8:11 PM