Single edit tab: Preferences dialog is not showing in Firefox (? on Macs only)
Closed, DeclinedPublic1 Story Points

Description

Steps to reproduce:

  1. Go to test2.wikipedia.org in Firefox and reset your preferences.
  2. Open any page.
  3. See the "Start editing" splash screen. Click through it.
  4. Start editing.
  5. Wonder why I didn't see that big preferences dialog for the single edit tab.

Result: No prefs dialog for single edit tab.
Expectation: Seeing the prefs dialog for single edit tab.

Firefox only; always happens; repeatedly reproduced on two different Macs/two different accounts. This currently appears to be a Mac-only problem.

Whatamidoing-WMF updated the task description. (Show Details)
Whatamidoing-WMF raised the priority of this task from to Needs Triage.
Whatamidoing-WMF added a subscriber: Whatamidoing-WMF.
Restricted Application added subscribers: StudiesWorld, Aklapper. · View Herald TranscriptDec 24 2015, 2:42 AM
Alsee added a subscriber: Alsee.Dec 24 2015, 3:03 AM

Apparently this isn't a Firefox issue.
https://www.mediawiki.org/w/index.php?title=Topic:Suspcq0bf5nd3gsd&topic_showPostId=sv4ojjy1c4aa0q7o#flow-post-sv4ojjy1c4aa0q7o
Firefox Win7. New account: Default VE.
Firefox Win7. IP edit: Default VE.
Chrome Win7. New account: Default VE.
Chrome Win7. IP edit: Default VE.

Unfortunately, it's impossible to determine from that brief list whether this comment means "I didn't ever see a prefs dialog" or "It's working correctly, since I always started in the editing environment that test2 is configured to offer first".

Alsee added a comment.EditedDec 24 2015, 10:28 PM

IE8 test: locked out completely. All that comes up when I create a new account and click EDIT is the link to report problems.
On EnWiki the wikitext editor comes up fine.

@Whatamidoing-WMF: I get both dialogs, one after the other, same in Chrome.

I'm running Firefox 41 on Mac OS 10.10.5. I'm not seeing the second dialog (as of 10 seconds before starting to type this reply). Are you testing this on a Mac?

No, not on a Mac.

TheDJ added a subscriber: TheDJ.Dec 30 2015, 6:46 PM

I can confirm what @Whatamidoing-WMF reported with FF 42.0 on Mac OS 10.11.2. I get the "Start editing" screen, but not the choice dialog.

If I look into the JS console, I see the following, which may or may not be related:

19:37:26.203 [Edit] Missing or empty schema1 load.php:37:129
<anonymous> load.php:37
handler() load.php:155
jQuery.Callbacks/fire() load.php:45
jQuery.Callbacks/self.fireWith() load.php:46
jQuery.Callbacks/self.fire() load.php:46
mw.track() load.php:155
self.prepare() load.php:35
self.logEvent() load.php:36
handleTrackedEvent/<() load.php:33
jQuery.Callbacks/fire() load.php:45
jQuery.Callbacks/self.fireWith() load.php:46
.Deferred/</deferred[tuple[0]]() load.php:47
handlePending() load.php:159
execute/runScript/markModuleReady() load.php:162
execute/runScript/<() load.php:162
jQuery.Callbacks/fire() load.php:45
jQuery.Callbacks/self.add() load.php:45
.Deferred/promise.always() load.php:46
execute/runScript() load.php:162
execute/</checkCssHandles() load.php:163
execute() load.php:163
mw.loader.implement() load.php:170
<anonymous> load.php:1

19:37:27.810 Exception in store-localstorage-update:1 load.php:177:493

19:37:27.811 NS_ERROR_DOM_QUOTA_REACHED: Persistent storage maximum size reached DOMException [NS_ERROR_DOM_QUOTA_REACHED: "Persistent storage maximum size reached"
code: 1014
nsresult: 0x805303f6
location: https://test2.wikipedia.org/w/load.php?debug=false&lang=en&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=%2Ba17lhsh:175]1 load.php:177:531
log() load.php:177
handler() load.php:155
jQuery.Callbacks/fire() load.php:45
jQuery.Callbacks/self.fireWith() load.php:46
jQuery.Callbacks/self.fire() load.php:46
mw.track() load.php:155
flushWrites() load.php:175
triggerIdle() load.php:178
Whatamidoing-WMF renamed this task from Single edit tab: Preferences dialog is not showing in Firefox to Single edit tab: Preferences dialog is not showing in Firefox on Macs.Jan 4 2016, 4:15 AM
Whatamidoing-WMF updated the task description. (Show Details)

I thought this might be caused by a call to localStorage.setItem (your local storage is full), but both of ours are in try blocks. I doubt it's related to Mac vs. other operating systems.
@Whatamidoing-WMF: Do you see anything in JS console when you reproduce this issue?

Elitre added a subscriber: Elitre.Jan 14 2016, 4:53 PM
Jdforrester-WMF renamed this task from Single edit tab: Preferences dialog is not showing in Firefox on Macs to Single edit tab: Preferences dialog is not showing in Firefox (? on Macs only).Jan 19 2016, 8:07 PM
Jdforrester-WMF triaged this task as High priority.
Jdforrester-WMF edited a custom field.
Jdforrester-WMF moved this task from To Triage to TR1: Releases on the VisualEditor board.

On Windows laptop both with Firefox and with Chrome created a new editor and didn't see the big preference dialog. This isn't a mac or ff exclusive issue.

I believe that the dialog is only shown to a user if all of the below are true:

  • they're logged in
  • they haven't disabled VE somehow (via preferences)
  • their tab preference is set to the default (remember last)
  • they've edited before a specific date/time (set by server configuration, currently defaulting to 1st January 2016)
  • they've never seen this dialog before (based on hidden preference)
Jdforrester-WMF closed this task as Declined.Jan 28 2016, 6:37 PM
Jdforrester-WMF added a subscriber: Jdforrester-WMF.

This is intentional. We're not going to warn users that haven't seen two tabs why they don't see two tabs.