Page MenuHomePhabricator

Upgrade PHP_CodeCoverage
Closed, ResolvedPublic

Description

We're on PHP_CodeCoverage 1.2.18, but 3.0.2 is out. However, that needs PHP 5.6. So we should be good to go for 2.2.4. Except we're using old phpunit

Probably about time for an upgrade... I'd do it myself, but can't obviously see where it's setup/installed (is it just some git checkout on gallium?)

Event Timeline

Reedy raised the priority of this task from to Needs Triage.
Reedy updated the task description. (Show Details)
Reedy added a subscriber: Reedy.
Reedy set Security to None.
hashar triaged this task as Low priority.Jan 5 2016, 1:18 PM
hashar added a subscriber: hashar.
Krinkle claimed this task.
Krinkle closed subtask T99982: Upgrade PHPUnit to 4.0+ as Resolved.
Krinkle removed a project: Release-Engineering-Team.

As part of T99982, phpunit/php-code-coverage was implicitly upgraded to v2.2.4 as it is a dependency of PHPUnit, which specifies which version it uses. (It shouldn't be overridden separately.)

First passing build with the new version:
https://integration.wikimedia.org/ci/job/mediawiki-core-code-coverage/1852/

https://integration.wikimedia.org/cover/mediawiki-core/master/php/

Yay!