Page MenuHomePhabricator

Redirect page with {{R from merge}} prevents merging of Wikidata item
Closed, InvalidPublic

Description

Consider this redirect page: https://en.wikipedia.org/w/index.php?title=Recumbent_effigy&action=edit. It has a macro that commands: " This redirect was kept in order to preserve this page's edit history after its content was merged into the target page's content. Please do not remove the tag that generates this text "

#REDIRECT [[Gisant]] {{R from merge}}

I want to merge https://www.wikidata.org/wiki/Q6642845 (representing this redirect page) to https://www.wikidata.org/wiki/Q17090833, but I get this error:

A conflict detected on enwiki: [[Q17090833]] with enwiki:Gisant, [[Q6642845]] with enwiki:Recumbent effigy

I guess the error is reported because of the extra macro on the redirect page. Can the merging code be generalized to also work on such pages? IMHO if there is #REDIRECT it should merge no matter what other text is on the page.

Event Timeline

VladimirAlexiev raised the priority of this task from to Needs Triage.
VladimirAlexiev updated the task description. (Show Details)
VladimirAlexiev added a project: Wikidata.
VladimirAlexiev added a subscriber: VladimirAlexiev.
Restricted Application added subscribers: StudiesWorld, Aklapper. · View Herald TranscriptDec 29 2015, 1:11 PM

The text generated by the macro mentions another macro with similar purpose {{R with history}}. This one (at least) should also be ignored by the merging code

Mbch331 closed this task as Invalid.Dec 29 2015, 1:20 PM
Mbch331 claimed this task.
Mbch331 added a subscriber: Mbch331.

This is caused by the fact that there are 2 items with sitelinks on Wikidata. Problem has been solved on Wikidata. Deleted the redirect from Q6642845 and then merged Q6642845 with Q17090833. Any sitelink to a redirect is considered a valid sitelink when merging, because Wikidata can't see if the target is a normal page or a redirect. Only the link itself is stored. These problems don't belong on Phabricator but on //www.wikidata.org/wiki/Wikidata:Project_chat.

Mbch331 triaged this task as Medium priority.Dec 29 2015, 1:21 PM
Mbch331 set Security to None.