Page MenuHomePhabricator

Uncommitted DB writes (transaction from DatabaseBase::query (DatabaseBase::query)) in Database.php
Closed, ResolvedPublic

Description

I got this following debug error message in my wiki (link: http://suriyaakudo.bplaced.net/w/index.php?title=Main_Page):

Notice: Uncommitted DB writes (transaction from DatabaseBase::query (User::loadFromDatabase)). in /users/suriyaakudo/www/w/includes/db/Database.php on line 4362

After I set at the end of my LocalSettings.php file this debug code:

$wgShowSQLErrors = true;
$wgDebugDumpSql  = true;


I use:

  • MediaWiki 1.25.2
  • PHP 5.5.21 (cgi-fcgi)
  • MariaDB 5.5.33a-MariaDB
  • Lua 5.1.5

It's an unsolved issue like T85762 and T85734!

Event Timeline

Maniphest changed the visibility from "Public (No Login Required)" to "Custom Policy".Jan 3 2016, 12:47 PM
Maniphest changed the edit policy from "All Users" to "Custom Policy".
suriyaa triaged this task as Medium priority.
suriyaa updated the task description. (Show Details)
suriyaa changed Security from None to Other confidential issue.
suriyaa edited subscribers, added: suriyaa; removed: Aklapper.

Why is this 'other confidential issue'?

suriyaa changed Security from Other confidential issue to None.Jan 4 2016, 11:37 AM

Sorry, I set it wrong.

Krenair changed the visibility from "Custom Policy" to "Public (No Login Required)".Jan 4 2016, 6:25 PM
Krenair changed the edit policy from "Custom Policy" to "All Users".
Krenair removed a project: WMF-NDA.
Krinkle changed the task status from Open to Stalled.May 8 2017, 1:34 AM
Krinkle removed a project: Wikimedia-Rdbms.
Krinkle added a subscriber: Krinkle.

Without more details, this cannot be acted upon. This issue does not happen on a plain MediaWiki install, so presumably it has something to do with either your configuration or the extensions installed making write queries without committing the changes.

@suriyaa Can you still reproduce this problem? Perhaps try disabling various extensions to narrow down the cause, or debug SQL errors (How to debug) to see which query is the problem.

@Krinkle I think it solved. I'm not working anymore on this old MediaWiki install.