Page MenuHomePhabricator

Moment.js does not support all Chinese languages that MediaWiki supports
Closed, ResolvedPublic

Description

For example, in Resources.php, localization for momentjs is defined for zh-CN, zh-TW, but not for zh-Hans, zh-Hant, etc. This will cause modules depending on momentjs to display English fallback if the interface language for the user is zh-Hans, for example.

Event Timeline

Nbdd0121 raised the priority of this task from to Needs Triage.
Nbdd0121 updated the task description. (Show Details)
Nbdd0121 added a subscriber: Nbdd0121.

Change 279416 had a related patch set uploaded (by Nbdd0121):
Fix T123080

https://gerrit.wikimedia.org/r/279416

matmarex renamed this task from Libraries used by MediaWiki do not support all languages MediaWiki supported to Moment.js does not support all Chinese languages that MediaWiki supports.Mar 24 2016, 7:49 PM
matmarex set Security to None.
matmarex added a subscriber: matmarex.

Change 279416 had a related patch set uploaded (by Bartosz Dziewoński):
Define 'zh-hans' and 'zh-hant' localisations for Moment.js

https://gerrit.wikimedia.org/r/279416

Change 279416 merged by jenkins-bot:
Define 'zh-hans' and 'zh-hant' localisations for Moment.js

https://gerrit.wikimedia.org/r/279416

matmarex assigned this task to Nbdd0121.

Thanks for the patch! The change has been merged and will be deployed to Wikimedia wikis next week, with MediaWiki version 1.27.0-wmf.19, according to the schedule at https://www.mediawiki.org/wiki/MediaWiki_1.27/Roadmap.