after switching from source to visual editing, #mw-content-text loses lang and dir attributes
Open, Stalled, LowPublic8 Story Points

Description

To reproduce:

  1. Go to https://en.wikipedia.org/wiki/User:Amire80/losing_attributes?setlang=he
  2. Edit the page in wiki syntax mode.
  3. Switch to visual editing.
  4. Change something.
  5. Save.

Observed: The direction of the page is right-to-left. The <div id="mw-content-text"> does not have the lang and dir attributes, which it is supposed to have.

This may be related to T119745.

(To switch your UI back to English go to https://en.wikipedia.org/wiki/User:Amire80/losing_attributes?setlang=en .)

Amire80 created this task.Jan 9 2016, 12:50 AM
Amire80 updated the task description. (Show Details)
Amire80 raised the priority of this task from to Needs Triage.
Amire80 added a project: VisualEditor.
Amire80 added subscribers: Amire80, Mooeypoo.
Restricted Application added subscribers: StudiesWorld, Aklapper. · View Herald TranscriptJan 9 2016, 12:50 AM
Jdforrester-WMF triaged this task as Low priority.Jan 26 2016, 8:14 PM
Jdforrester-WMF set Security to None.
Jdforrester-WMF edited a custom field.
Jdforrester-WMF moved this task from To Triage to Backlog on the VisualEditor board.

Works fine for me. Checked the code as well: all we do is empty mw-content-text and replace its contents, but not attributes.

Jdforrester-WMF changed the task status from Open to Stalled.May 10 2016, 4:28 PM
Amire80 updated the task description. (Show Details)May 10 2016, 6:37 PM

My bad! I should have properly emphasized that this happens after editing in wiki syntax and then switching to VE. I updated the instructions in the initial description.