Page MenuHomePhabricator

[Regression] Investigate and fix QuickSurveys browser tests
Closed, ResolvedPublic

Description

The QuickSurveys nightly browser test run has been failing since Monday, 28th December 2015. Let's fix 'em.

Event Timeline

phuedx created this task.Jan 13 2016, 11:09 PM
phuedx raised the priority of this task from to Needs Triage.
phuedx updated the task description. (Show Details)
phuedx added projects: QuickSurveys, Regression.
phuedx added a subscriber: phuedx.
Restricted Application added subscribers: StudiesWorld, Aklapper. · View Herald TranscriptJan 13 2016, 11:09 PM
dr0ptp4kt triaged this task as High priority.Jan 18 2016, 4:51 PM

This is because I1e5c5af8066a5b905b54580e459b0651387c86d3 never got released. Someone needs to make a QuickSurveys release. Hence why https://phabricator.wikimedia.org/T122516#1908831 still in sign off.

phuedx claimed this task.Jan 20 2016, 5:58 PM

The latest version of QuickSurveys has been released but the build is still failing.

Change 265476 had a related patch set uploaded (by Phuedx):
NOP

https://gerrit.wikimedia.org/r/265476

Change 265476 abandoned by Phuedx:
NOP

Reason:
Of course we don't run QUnit tests on a per-commit basis…

https://gerrit.wikimedia.org/r/265476

Change 265482 had a related patch set uploaded (by Phuedx):
Fix the failing QUnit tests

https://gerrit.wikimedia.org/r/265482

Change 265482 merged by jenkins-bot:
Fix the failing QUnit tests

https://gerrit.wikimedia.org/r/265482

See T124309 - we'll get that fixed asap. Not sure how that slipped through code review my bad I guess :/

Change 265539 had a related patch set uploaded (by Paladox):
Fix the failing QUnit tests

https://gerrit.wikimedia.org/r/265539

So it was failing because we didn't do a release obvvvioussllyyy. Given our chat today, I've merged Paladox's cherry pick to master.
Will report back.

Change 265539 merged by jenkins-bot:
Fix the failing QUnit tests

https://gerrit.wikimedia.org/r/265539

Jdlrobson reassigned this task from Jdlrobson to phuedx.Jan 21 2016, 10:19 PM

Re-assigning to Sam since I think his patch should be enough.
Waiting for http://en.m.wikipedia.beta.wmflabs.org/wiki/Quick_survey_test_page_stub?quicksurvey=true to work and then I'll re-run the build.

Still failing.
I'm lost as when I run them locally they pass.
Have sent a mail to the QA list about T105589 as it would really help to be able to debug what's going on here

So I'm pretty sure what's happening here is the browser tests on Jenkins run on the mobile site and when run on commit they run on desktop! Confusing!
I reckon thus that https://phabricator.wikimedia.org/T124361 is the cause so working on a fix.

I'm certain that this and T124361 will be fixed by updating the version of QuickSurveys on the Beta Cluster (currently, it's showing v1.1.1 and I've just released v1.1.2). Consequently, I've moved this to -1 (Needs More Work) but I'm not sure who needs to do more work…

phuedx added a subscriber: hashar.Jan 22 2016, 10:41 AM

Waiting for the Beta Cluster to be updated – it hadn't been updated for some 9 hours /cc @hashar

Jdlrobson closed this task as Resolved.Jan 22 2016, 5:06 PM

I'm signing this off! Good work Sam!