Page MenuHomePhabricator

All Campaign namespace pages can't be saved
Closed, ResolvedPublic

Description

All Campaign namespace pages can't be saved at the moment on Commons, with the error message Value "cc-by-sa-4.0" not in enum for property cc-by-sa-3.0. I was able to reproduce locally too. I don't know yet why, but I'll find out.

Originally reported at https://commons.wikimedia.org/wiki/Commons:Village_pump#Incomprehensible_error_message_does_not_let_any_Campaign_edits by @Poco_a_poco.

Event Timeline

matmarex created this task.Jan 16 2016, 7:24 PM
matmarex claimed this task.
matmarex raised the priority of this task from to Unbreak Now!.
matmarex updated the task description. (Show Details)
matmarex added a project: UploadWizard.
matmarex added subscribers: matmarex, Poco_a_poco.
Restricted Application added a project: Multimedia. · View Herald TranscriptJan 16 2016, 7:24 PM
Restricted Application added subscribers: Steinsplitter, Aklapper. · View Herald Transcript

Change 264578 had a related patch set uploaded (by Bartosz Dziewoński):
Revert "Define required 'defaults' field in licensing config"

https://gerrit.wikimedia.org/r/264578

Restricted Application added a subscriber: Matanya. · View Herald TranscriptJan 17 2016, 10:40 AM

Change 264695 had a related patch set uploaded (by Bartosz Dziewoński):
Revert "Define required 'defaults' field in licensing config"

https://gerrit.wikimedia.org/r/264695

Change 264697 had a related patch set uploaded (by Bartosz Dziewoński):
Define required 'defaults' field in licensing config, correct the code using it

https://gerrit.wikimedia.org/r/264697

Change 264578 merged by jenkins-bot:
Revert "Define required 'defaults' field in licensing config"

https://gerrit.wikimedia.org/r/264578

matmarex closed this task as Resolved.Jan 18 2016, 8:11 PM

Patch has been merged, so I'm closing this. The issue is still present on Commons and will be fixed there tomorrow around 16:00 UTC, when the patch is deployed (schedule).

Change 264695 merged by jenkins-bot:
Revert "Define required 'defaults' field in licensing config"

https://gerrit.wikimedia.org/r/264695

Change 264969 had a related patch set uploaded (by Bartosz Dziewoński):
Revert "Define required 'defaults' field in licensing config"

https://gerrit.wikimedia.org/r/264969

That didn't happen, I was sick and wasn't around to get the patch deployed. Will try again.

Change 264969 abandoned by Bartosz Dziewoński:
Revert "Define required 'defaults' field in licensing config"

Reason:
Hold on, wtf

https://gerrit.wikimedia.org/r/264969

Change 264969 restored by Bartosz Dziewoński:
Revert "Define required 'defaults' field in licensing config"

Reason:
OK

https://gerrit.wikimedia.org/r/264969

Change 264969 merged by jenkins-bot:
Revert "Define required 'defaults' field in licensing config"

https://gerrit.wikimedia.org/r/264969

Change 264697 merged by jenkins-bot:
Define required 'defaults' field in licensing config, correct the code using it

https://gerrit.wikimedia.org/r/264697