Page MenuHomePhabricator

The notifications drop down menu displays numbers using the wrong numeral system on Arabic Wikipedia (arwiki)
Closed, ResolvedPublic

Description

(This bug happened only after the recent changes in the notifications system.)

There are two numeral systems:

  1. Western Arabic Numerals
  2. Eastern Arabic Numerals
  • When using Arabic (ar) as a content language, MediaWiki uses Eastern Arabic numerals as the number system by default.
  • However, Arabic Wikipedia (arwiki) overrides this and uses Western Arabic numerals.
  • After the recent upgrade of the notifications system, the numbers in the drop down menu are rendered using Eastern Arabic numerals.

Request:

  • Numbers in the notification drop down menu should be rendered using Western Arabic numerals on Arabic Wikipedia to be consistent with the numbering system on the wiki.

Note:

  • The numbers on the local Special:Notifications are correctly rendered using the Western Arabic numerals. So, the problem is in the drop down menu only.

Google Chrome 47 under Windows 8

Event Timeline

Meno25 created this task.Jan 16 2016, 8:42 PM
Meno25 raised the priority of this task from to Needs Triage.
Meno25 updated the task description. (Show Details)
Meno25 added a project: Notifications.
Meno25 added a subscriber: Meno25.
Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptJan 16 2016, 8:42 PM
Restricted Application added subscribers: StudiesWorld, Aklapper. · View Herald Transcript
Meno25 renamed this task from On Special:Notifications, numbers are rendered using the wrong numeral system on Arabic Wikipedia (arwiki) to The notifications drop down menu displays numbers using the wrong numeral system on Arabic Wikipedia (arwiki).Jan 17 2016, 6:50 AM
Meno25 set Security to None.

This only applies to the timestamp ("6 hours ago"), right? I think that's because the notification pop-up uses moment.js to render the timestamp, and moment doesn't know about $wgTranslateNumerals = false;

This only applies to the timestamp ("6 hours ago"), right? I think that's because the notification pop-up uses moment.js to render the timestamp, and moment doesn't know about $wgTranslateNumerals = false;

Yes. The only problem I see is in the timestamps of the drop down menu. For example, mine now shows:
منذ ٣ أيام
(3 days ago)
منذ ٤ أيام
(4 days ago)
etc

Change 281187 had a related patch set uploaded (by Catrope):
Fix regression from 0fc63bde365: unbreak number formatting in short timestamps

https://gerrit.wikimedia.org/r/281187

Catrope closed this task as Resolved.Apr 2 2016, 3:51 PM
Catrope claimed this task.

This bug was fixed by accident as part of T125970: Use more compact timestamps for notifications, because we broke all number formatting. https://gerrit.wikimedia.org/r/281187 unbreaks number formatting but preserves the behavior requested in this bug, because the new code respects $wgTranslateNumerals.

Change 281187 merged by jenkins-bot:
Fix regression from 0fc63bde365: unbreak number formatting in short timestamps

https://gerrit.wikimedia.org/r/281187

Restricted Application added a subscriber: TerraCodes. · View Herald TranscriptApr 20 2016, 12:02 AM

Side-note: There's some details about this overall issue at https://www.mediawiki.org/wiki/Talk:Localisation#Languages_that_use_non-arabic_numerals_in_their_ToC - if any devs want to merge that to a better location, please do. (I put parts of it in https://www.mediawiki.org/wiki/Manual:$wgTranslateNumerals but I wasn't sure where else it belongs. Perhaps in https://www.mediawiki.org/wiki/Localisation#cite_note-6 ?)