Page MenuHomePhabricator

[Bug] Edits made with mobile content service enabled show old page copy
Closed, ResolvedPublic

Description

Description

Steps to reproduce

  1. Force mobile content service usage.
  2. Go to the Niedzielski edit test article on the test wiki.
  3. Make an edit.
  4. Force refresh.

Expected results

The result of the edit is seen.

Actual results

The article prior to the edit is shown. This isn't an issue using MW API.

Environments observed

App version: 55014be [0]
Android OS versions: API 23
Device model: Nexus 6P
Device language: English

[0] https://www.mediawiki.org/wiki/Wikimedia_Apps/Team/RESTBase_services_for_apps/Deployments#Wednesday.2C_January_13.2C_2016_around_4:30pm_PT:_Y.C2.A0Deployed_c9e7e28_.28updating_to_300bd47.29

Event Timeline

Niedzielski raised the priority of this task from to High.
Niedzielski updated the task description. (Show Details)
Niedzielski added a subscriber: Niedzielski.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 18 2016, 5:00 PM
bearND added a subscriber: bearND.Feb 4 2016, 5:20 PM

It does show up but it takes a couple of seconds. It could be that when you first tried this initial pre-generation was running and the servers were busy.

Having said that, I think the UX is not great. I'm looking for suggestions on how to improve it. I guess we could poll until a change is detected (e.g. when a new etag / revision is detected). Until then keep spinning or better show a Snackbar.

@bearND, I think I see a similar issue in updating a Wikidata subtitle description, which I believe are transclusions. A couple minutes and still no update.

bearND added a subscriber: mobrovac.EditedFeb 4 2016, 9:12 PM

@Niedzielski Wikidata descriptions are a very different case. Descriptions are not retrieved via transclusions/HTML. We get that via the description field in JSON, which is populated by action=mobileview API.

There are probably currently no mechanisms in place to trigger an update of the page content when the Wikidata short description has be changed. Is this correct @mobrovac?

@bearND, weird. The MW API appeared to show it right away. Maybe just an app side caching issue?

bearND added a comment.Feb 4 2016, 9:15 PM

@Niedzielski The problem is that the MCS page content only gets updated when RB thinks there is something to update (through a new revision or template data update). The description field is not one of those cases.

@Niedzielski The problem is that the MCS page content only gets updated when RB thinks there is something to update (through a new revision or template data update). The description field is not one of those cases.

That's correct. Unfortunately for the time being Wikidata updates are done separately and work on the database itself, so don't trigger revision creation events, as normal template updates do. We are working this quarter on a change propagation system and are in contact with Wikidata guys to (eventually) solve this problem. Stay tuned :)

RB now purges page storage and cache when a page template gets updated. So, from a service perspective the work is complete. We could add something to the app code to ensure that after a successful edit the app retries to get a new revision of the page. Until then keep spinning or show a Snackbar.

bearND moved this task from Tracking to Needs Triage on the Wikipedia-Android-App-Backlog board.

The app work for this is now in a new card: T132803

bearND closed this task as Resolved.Apr 15 2016, 4:42 PM
bearND claimed this task.