Page MenuHomePhabricator

Adding an invaild claim makes the edit box disabled (uneditable)
Closed, ResolvedPublic

Description

Reproduce:

  1. Try to add an invaild claim (URL, string, media file...) to edit box.
  2. Press save, and an error occurs.
  3. Now the content in edit box is no longer editable.

Related Objects

Event Timeline

Bugreporter updated the task description. (Show Details)
Bugreporter raised the priority of this task from to Needs Triage.
Bugreporter added a subscriber: Bugreporter.
Restricted Application added subscribers: StudiesWorld, Aklapper. · View Herald TranscriptJan 20 2016, 7:10 PM
hoo added a subscriber: hoo.Jan 20 2016, 10:11 PM

I'm not able to reproduce this in either Firefox or Midori. Can you give exact steps for reproducing this? Which browser(s) did you test?

I use Chrome-like browser. user-agent:Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/38.0.2125.122 Safari/537.36 SE 2.X MetaSr 1.0
The textarea is disabled:
<textarea class="valueview-expert-StringValue-input valueview-input" disabled="" style="height: 20px; overflow: hidden; resize: none;"></textarea>
Together with the snak type selector:
<span class="ui-state-default wikibase-snaktypeselector wikibase-SnakTypeSelector-disabled ui-state-disabled" aria-disabled="disabled"><span class="ui-icon ui-icon-snaktypeselector"></span></span>
but not the rank selector.

Note: I found another bug while trying to reproduce this one, at T124271: Saving one claim saves two.

Bugreporter renamed this task from Adding an invaild URL makes the edit box disabled (uneditable) to Adding an invaild claim makes the edit box disabled (uneditable).Jan 21 2016, 9:22 AM
Bugreporter updated the task description. (Show Details)
Bugreporter set Security to None.

I found that this bug also occurs while adding claims of other datatype. Changed the bug name.

hoo added a comment.Jan 21 2016, 9:25 AM

Where do you see this behaviour? On Wikidata.org? If so, could you please go to https://test.wikidata.org/ and see whether the problem occurs there as well (just to rule out potential causes like faulty gadgets or user scripts).

The bug occurs at both place.

also at wikidata.beta.wmflabs.org

hoo added a comment.Jan 21 2016, 9:33 AM

Could you please try another browser (maybe something that is not Blink based)

I have not installed Firefox.

hoo added a comment.Jan 21 2016, 9:40 AM

If you have Windows, you might want to try Microsoft Internet Explorer/ Edge.

Do you see any JavaScript errors when this occurs? Try pressing F12 to see these, although that might be different for your browser.

Because I'm using an old version of Windows I don't have Internet Explorer 9+ or Edge.
I don't see any JavaScript error.

hoo added a comment.Jan 21 2016, 9:56 AM

Do you have any addons installed that could be troublesome? Things like ad blockers or noscript can interfere with our scripts, you might want to try to disable these temporarily.

No. I also disabled all gadgets and user scripts.

hoo added a comment.Jan 21 2016, 1:05 PM

Looking at this again, your Chrome-like browser seems to be very old (based upon a Chrome version from October 2014). Did you consider updating it?

Based on the comments here I assume that has been fixed. Please reopen when not.

samuwmde closed this task as Resolved.Feb 7 2018, 3:30 PM
samuwmde claimed this task.