Page MenuHomePhabricator

Organize a technical workshop at WikiArabia (Amman, Jordan, March 24-26)
Closed, ResolvedPublic

Description

WikiArabia 2016 is held in Amman at the end of March, one week before the Wikimedia Hackathon in Jerusalem. The organization inviting us to organize a technical session. Amman and Jerusalem are pretty close geographically, but politically it takes about 5 hours of car + borders. Still, it is an interesting idea.

We are defining the details as we speak. We are still learning about the audience in Amman (more technical editors or also some developers?).

Saturday, 26 March

Open session: Introduction to Wikimedia Tech
An overview of the Wikimedia software stack from the MediaWiki engine and its extensions to gadgets, templates, and bots. How to get involved in our open source projects. How to start creating your own tools and features using the Wikimedia infrastructure, with the support of our technical community.
Audience: developers and free software enthusiasts; tech-curious editors too. Not a specialized developer session.
Duration: 50 minutes?
Needs: projector.

Regular WikiArabia session: Introduction to Wikimedia Phabricator
How to use our task management system to report technical problems, request features, and follow ongoing work in your favorite projects.
Audience: Everybody, this session is non-tech friendly too.
Duration: 50 minutes?
Needs: projector.

See also T124721: Organize a technical workshop in Ramallah (Palestine, 30 March 2016)

Event Timeline

Rfarrand created this task.Jan 20 2016, 8:18 PM
Rfarrand raised the priority of this task from to Medium.
Rfarrand updated the task description. (Show Details)
Rfarrand added subscribers: Rfarrand, Qgil, Aklapper.

Noting that User:Fjmustak who is based in Ramallah has also offered to set up some sort of technical session at Birzeit University as a possible satellite event to the Jerusalem Hackathon.

This could be considered separately from this decision around WikiArabia in Jordan (it could alternatively be a bridge between the two in the intervening time). Should that be captured in a Phabricator ticket somehow?

aude added a subscriber: aude.EditedJan 21 2016, 4:32 PM

would be interested to attend WikiArabia, since i know some arabic :) and could help them with wikidata topics (assuming i am able to attend the hackathon)

Qgil added a comment.Jan 21 2016, 5:02 PM

Noting that User:Fjmustak who is based in Ramallah has also offered to set up some sort of technical session at Birzeit University as a possible satellite event to the Jerusalem Hackathon.

Great! Very exciting.

This could be considered separately from this decision around WikiArabia in Jordan (it could alternatively be a bridge between the two in the intervening time). Should that be captured in a Phabricator ticket somehow?

Yes, please create a task and propose a date. We can continue discussing the organization of this session in the new task.

Qgil added a comment.Jan 21 2016, 5:05 PM

@aude, what a surprise! As soon as we have a minimum tech plan for WikiArabia, we will advertise it. We hope to see/promote some cross pollination between the events in Amman, Ramallah, and Jerusalem.

I will be attending WikiArabia and traveling back to Jerusalem/Ramallah. I have also registered for the Jerusalem hackathon (attendance not confirmed).
WikiArabia: Mar 24-26
Hackathon: Mar 31-Apr 3

I propose holding the event in Ramallah or Birzeit during the week in between, perhaps Monday, the 28th. Birzeit University is off on Sundays (additionally the 27th is Easter Sunday according to the Gregorian calendar). I will probably be traveling back to Palestine on Sunday.

Additionally, I can help with the logistics and escort those traveling back from Amman.

Is there a phabricator ticket for a possible session in Ramallah/Birzeit yet, where we can further discuss it?

Qgil added a subscriber: Moushira.Jan 25 2016, 11:18 AM
Qgil renamed this task from Andre, Quim & Rachel F from Developer Relations team to attend WikiArabia Conference in advance of the Jerusalem Hackathon. to Organize a technical workshop at WikiArabia (Amman, end of March 2016).Jan 25 2016, 10:28 PM
Qgil updated the task description. (Show Details)
Qgil set Security to None.
Qgil renamed this task from Organize a technical workshop at WikiArabia (Amman, end of March 2016) to Organize a technical workshop at WikiArabia (Amman, Jordan, March 24-26).Jan 25 2016, 10:32 PM
Qgil updated the task description. (Show Details)
Qgil added a comment.Jan 25 2016, 10:46 PM

@Fjmustak Let's define here the details about WikiArabia, and let's discuss the workshop in Ramallah at {See also T124721: Organize a technical workshop in Ramallah (Palestine, 30 March 2016).

Please correct me if I'm wrong, but it seems that the WikiArabia audience will be formed mostly by editors / admins. Do you expect developers as well? We need to know the audience in order to send the right profiles.

Let's decide the day of the workshop in Amman so we can book our trip accordingly. I also wonder whether we should fly to Jerusalem or Amman. I have no idea how easy it is for foreigners (mostly USA/EU) to go to/from Jerusalem / Amman, and whether there is significant difference of prices.

@Qgil, WikiArabia will be attended by editors/admis as well as a few developers (from the participant list, I can count three or four, and these exclude Jordanian participants). I would suggest holding a wider session for the open source community in Jordan, and not just for the participants of WikiArabia. That should have a greater impact. Please share your thoughts on the preferred target audience.

As for flights, there are more direct flights from European airports to Tel Aviv than to Amman, and they are usually a bit cheaper. An option to consider would be flying into Amman and out of Tel Aviv, that way you would minimize travel by land (there are flights between TLV-AMM, but I prefer going by land). For the US, there's no significant difference, for example SFO-TLV and SFO-AMM are pretty much the same price ($700-1100 in that date range, with no direct flights).

Border crossing should not be an issue for internationals.

I propose the workshop to be held on the final day of the conference (Saturday the 26th), in order to minimize the length of your overall trip (you're certainly welcome to stay for the whole duration of course!).

Qgil added a comment.Jan 26 2016, 11:27 AM

OK, thank you for these details.

What about this:

Saturday 26:

Open session: Introduction to Wikimedia Tech
An overview of the Wikimedia software stack from the MediaWiki engine and its extensions to gadgets, templates, and bots. How to get involved in our open source projects. How to start creating your own tools and features using the Wikimedia infrastructure, with the support of our technical community.
Audience: developers and free software enthusiasts; tech-curious editors too. Not a specialized developer session.

Regular WikiArabia session: Introduction to Wikimedia Phabricator
How to use our task management system to report technical problems, request features, and follow ongoing work in your favorite projects.
Audience: Everybody, this session is non-tech friendly too.

@Aklapper can drive the first session, ideally with the help of a Wikimedia developer to be defined, and he is the expert for the Phabricator session.

@Qgil I like these ideas. The regular session at WikiArabia sounds good, and may create interest in the open session.
I will discuss the open session with the local organizing team in Amman.
Again, we'll need to advertise it soon, and it would be a good idea to cross promote the Amman and Ramallah sessions, once they've been finalized.

Qgil added a comment.Jan 28 2016, 9:00 AM

You can advertise these sessions already. The only missing piece is the developer to co-present the open session. Working on it.

Qgil updated the task description. (Show Details)Feb 1 2016, 7:31 AM
Qgil updated the task description. (Show Details)
aude added a comment.Feb 5 2016, 4:29 PM

I'm wondering where I would be able to propose a session(s) about Wikidata?

it looks like Amir (ladsgroup) [1] is also attending, so I would want to coordinate with him.

topics i could cover include perspective of the development team (and contributing to wikibase), and reusing + querying wikidata content (e.g. wikidata query service, wikidata toolkit and dumps).

Also could do something more general such as how to edit wikidata, what kind of properties we have and how to find the, how community aspects work like proposing properties related topic could be how to use wikidata from within Wikipedia (and sister projects), using lua.

also maybe a hands-on editing session?

[1] https://meta.wikimedia.org/wiki/WikiArabia/2016/Participants

Yeah, I will be there, I probably have two presentations. First about ORES and the second one would be about Wikidata tools (Wikidata-Game, SPARQL, etc.) We can have some workshops about Wikidata and ORES but that depends on programs committee.

@aude check with Mervat Salman ([[User:Mervat_Salman]]), she's in charge of WikiArabia, and can help you with scheduling a talk at the conference.

Will you also be coming to Ramallah? There is great interest in WikiData, and you're welcome to present here.

Aklapper claimed this task.EditedFeb 10 2016, 5:55 PM

If I get it right, I'm summarizing what I see as ToDo's here:

  • @Qgil to please find a developer to co-present the open session.
  • @Mervat to please schedule the two sessions Introduction to Wikimedia Tech (preferably at the beginning of Saturday 26th) and Introduction to Wikimedia Phabricator (on Saturday 26th) on the program.
  • @Mervat to please explain/clarify how @aude can propose a session(s) about Wikidata (preferably on-wiki and linking to it from here?)

Please correct me if I'm wrong. Bonus points for answering / resolving the actual items. :D

aude added a comment.Feb 11 2016, 1:24 PM

I have talked with Mervat and think we are okay regarding sessions about WIkidata (coordinated with @Ladsgroup) and probably also do something about maps / openstreetmap (+graphs) since there's a lot new in the past year for the topic.

aude added a comment.Feb 11 2016, 1:29 PM

@Fjmustak would also be interested in presenting in Ramallah. Just let me know how long a session you want and if there are particular aspects to focus on?

(also if you want something about openstreetmap, generally, and/or about maps etc. in Wikimedia, I could do that. I've been involved with openstreetmap for 7-8 years and am a member of the Humanitarian OpenStreetMap Team)

@Aklapper: Two sessions have been scheduled as explained in the introduction. @aude will participate with @Ladsgroup in the presentations of WikiData Tools. I will talk to her again to make sure she and Amir are on the same page.

Regards

TFlanagan-WMF added a comment.EditedFeb 17 2016, 8:37 PM

I would kindly ask that anyone who will be attending WikiArabia in Amman please add themselves to the Participant List on Meta.

The organizers would like to nail down a head count and plan for things like hotel rooms :)

@Qgil @Rfarrand @Aklapper: Two hours have been reserved for the two sessions on March 26.

@Mervat: Thank you!

Strictly speaking this task is probably resolved, or is anything else left to do here?

Aklapper moved this task from Backlog to Doing on the DevRel-February-2016 board.Feb 27 2016, 4:43 PM
Aklapper closed this task as Resolved.Feb 29 2016, 12:07 PM

Great! Thank you everybody!

Qgil added a comment.Mar 30 2016, 9:49 AM

Could someone write a short summary of these tech sessions, how they went? Also, did anyone take any pictures?

@Qgil , The official photos *should* come out on Saturday. I can compile the photos related to the technical sessions by @Aklapper and @aude