During the initial round of creating the schemas for basic MediaWiki events (originally contained in this PR, now residing in its own repo), there were some comments which have not been fully discussed or addressed. This is a follow-up ticket to try to address / clarify any low-hanging fruit. I'll try to summarise the current state of affairs for each of issues below, all of which address the naming conventions adopted for the event schemas.
The current edit schema uses save_dt for storing the time stamp, while the canonical name of the field as referred to it in MediaWiki is timestamp. Renaming the field gives it more clarity and specificity (as in, timestamp as the name itself is too broad). The counterargument is that we shouldn't change field names promoted by MediaWiki if we don't have to. Along the same lines, there is a suggestion to also rename the following fields:
- summary into comment
- parent_revision_id into parent_id