Page MenuHomePhabricator

undefined method `test_name' for #<MediawikiSelenium::Environment:0x007f8d49e7e770> (NoMethodError)
Closed, ResolvedPublic

Description

Reported in T105589#1970175

Reproduced on local instance of mediawiki-vagrant with multimediaviewer role enabled.

$ bundle exec cucumber features/mmv.performance.feature:4
@en.wikipedia.beta.wmflabs.org @custom-browser @mediawiki.org @firefox @internet_explorer_8 @internet_explorer_9 @internet_explorer_10 @internet_explorer_11 @test2.wikipedia.org
Feature: Multimedia Viewer performance

  Background:                                                      # features/mmv.performance.feature:4
    Given I am using a custom user agent                           # features/step_definitions/mmv_performance_steps.rb:26
      undefined method `test_name' for #<MediawikiSelenium::Environment:0x007f9a36bb0df0> (NoMethodError)
      ./features/step_definitions/mmv_performance_steps.rb:27:in `/^I am using a custom user agent$/'
      features/mmv.performance.feature:5:in `Given I am using a custom user agent'
    And I am at a wiki article with at least two embedded pictures # features/step_definitions/mmv_steps.rb:3

0 scenarios
2 steps (1 failed, 1 skipped)
0m0.027s

Event Timeline

zeljkofilipin raised the priority of this task from to Normal.
zeljkofilipin updated the task description. (Show Details)
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 28 2016, 12:19 PM

Looks like test_name() no more exists in mediawiki_selenium 1.6.x. Apparently replaced by something like: scenario.title.

zeljkofilipin moved this task from Inbox to In Progress on the Browser-Tests-Infrastructure board.

This is breaking all MMV selenium tests. :(

In fe66fdc6be91 test_name has been removed.

Change 272980 had a related patch set uploaded (by Zfilipin):
Fix "undefined method test_name" error message in Selenium tests

https://gerrit.wikimedia.org/r/272980

Change 272980 merged by jenkins-bot:
Fix "undefined method test_name" error message in Selenium tests

https://gerrit.wikimedia.org/r/272980

zeljkofilipin closed this task as Resolved.Feb 24 2016, 3:08 PM

Manually triggered a few of them.

The one hitting mediawiki.org will keep falling until patch is cherry picked to the wmf branch.

Change 273190 had a related patch set uploaded (by Hashar):
Fix "undefined method test_name" error message in Selenium tests

https://gerrit.wikimedia.org/r/273190

Change 273190 merged by jenkins-bot:
Fix "undefined method test_name" error message in Selenium tests

https://gerrit.wikimedia.org/r/273190