Page MenuHomePhabricator

ext.guidedTour gives malformed uri sequence at nowiki
Closed, ResolvedPublic

Description

From console in Firebug

Exception in module-execute in module ext.guidedTour:
load.ph... (line 177)

URIError: malformed URI sequence
URIError: malformed URI sequence

load.ph... (line 177)
URIError: malformed URI sequence

Event Timeline

jeblad created this task.Feb 4 2016, 11:45 AM
jeblad updated the task description. (Show Details)
jeblad raised the priority of this task from to Needs Triage.
jeblad added a subscriber: jeblad.
Restricted Application added subscribers: StudiesWorld, Aklapper. · View Herald TranscriptFeb 4 2016, 11:45 AM

The bug appears when writing an article in source mode. Seems like VisualEditor works. In source mode the toolbar is gone.

Sometimes there is also an error (probably the same error)

Exception in module-execute in module ext.centralNotice.startUp:
load.ph... (line 177)
URIError: malformed URI sequence
URIError: malformed URI sequence

What are steps to reproduce? Do I go to https://no.wikipedia.org/ and create a new user account to get GuidedTour?

jeblad added a comment.Feb 4 2016, 2:38 PM

It was visible on all action=edit, but it is gone now.

Close the report as resolved?

Somehow it must have been resolved...
Perhaps an "pjoltergeist"!

It was visible on all action=edit, but it is gone now.

Please provide a full URL.

jeblad added a comment.Feb 4 2016, 8:00 PM

A full url to a bug that is gone? =)

It was this page openied with the URL
https://no.wikipedia.org/w/index.php?title=Bruker:Jeblad/s%C3%B8kem%C3%B8nstre&action=edit

that first failed. After first noticing I checked several pages to see if the bug was consistent.

Mattflaschen-WMF closed this task as Invalid.Feb 4 2016, 10:58 PM
Mattflaschen-WMF claimed this task.

Reopen if it occurs again. And if so add &debug=true to the URL to try to get better debugging information.

jeblad added a comment.EditedFeb 8 2016, 2:49 PM

Bug is back...

https://no.wikipedia.org/w/index.php?title=Freya_%28radar%29&action=edit&debug=1
https://no.wikipedia.org/w/index.php?title=Maldiskusjon:Trenger_oppdatering&action=edit&section=1&debug=1

URIError: malformed URI sequence
return unRfc2068(decodeURIComponent(s.replace(pluses, ' ')));

jquery.cookie.js (line 17, col 20)

Will try a hard reload (clearing whole cache)
Nope, did not solve the problem.

This is on Firefox 44, on Ubu 15.04

Thanks for the trace.

I don't see a JS error currently at either of those pages.

I'm not sure how the tour is triggering.

Does the tour ever show correctly? Do you know what started the tour?

Running:

mw.loader.using( 'mediawiki.inspect' ).done( function () { console.log( mw.inspect.getDependencyGraph()['ext.guidedTour'].requiredBy ); } );

may tell us what is triggering GuidedTour to load.

Mattflaschen-WMF reopened this task as Open.Feb 9 2016, 10:08 PM
Mattflaschen-WMF set Security to None.
jeblad added a comment.EditedFeb 15 2016, 2:28 PM

For a long time (at least several days!) it was gone, then late yesterday (Sun 14th Feb.) it was back. The bug is present at nowiki, but it is not present at nnwiki (I think it is on another cluster?) and enwiki (which is on another cluster).

Bug while editing pages is

URIError: malformed URI sequence
return unRfc2068(decodeURIComponent(s.replace(pluses, ' ')));

File is (again)
https://no.wikipedia.org/static/1.27.0-wmf.13/resources/lib/jquery/jquery.cookie.js

It is most noticeable because WikiToolbar disappears, and it becomes impossible to navigate the SpecialPreference. A lot of js-gadgets breaks (the live search for example) which makes the bug rather annoying.

Added to my common.js

mw.loader.using( 'mediawiki.inspect' ).done( function () { console.log( mw.inspect.getDependencyGraph()['ext.guidedTour'].requiredBy ); } );

But note that this is a js-script and the js-scripts are already croacked..

Found hi-entropy localStorage: 149.49164857190115  bits https://no.wikipedia.org/wiki/Bruker:Jeblad wmE-sS-sessionId
Bruker:Jeblad (line 65)
Exception in module-execute in module ext.centralNotice.startUp:
load.ph...WmIJl0K (line 177)
URIError: malformed URI sequence
URIError: malformed URI sequence
	

...egExp($.map(array,mw.RegExp.escape).join('.*?')+'$'),oldTitle=titleElement.title...

load.ph...WmIJl0K (line 177)
Exception in module-execute in module mediawiki.action.view.postEdit:
load.ph...WmIJl0K (line 177)
URIError: malformed URI sequence
URIError: malformed URI sequence
	

...egExp($.map(array,mw.RegExp.escape).join('.*?')+'$'),oldTitle=titleElement.title...

load.ph...WmIJl0K (line 177)
Exception in module-execute in module ext.guidedTour:
load.ph...WmIJl0K (line 177)
URIError: malformed URI sequence
URIError: malformed URI sequence
	

...egExp($.map(array,mw.RegExp.escape).join('.*?')+'$'),oldTitle=titleElement.title...

load.ph...WmIJl0K (line 177)
Exception in load-callback in module mediawiki.inspect:
load.ph...WmIJl0K (line 177)
TypeError: mw.inspect.getDependencyGraph(...)['ext.guidedTour'] is undefined
TypeError: mw.inspect.getDependencyGraph(...)['ext.guidedTour'] is undefined
	

...ions=[[/(Firefox|MSIE|KHTML,?\slike\sGecko|Konqueror)/,''],['Chrome Safari','Chr...

load.ph...WmIJl0K (line 177)
URIError: malformed URI sequence
	

...oldTitle){return;}if(accessKeyLabel){newTitle+=mw.msg('word-separator')+mw.msg('...

	
load.ph... > eval (line 6, col 681)
jeblad updated the task description. (Show Details)Feb 15 2016, 2:38 PM

Firefox 43.0.4 on Win10 does not bug out, even if some code croak

On call
https://no.wikipedia.org/w/index.php?title=Bruker:Jeblad&action=edit&debug=1

Found hi-entropy localStorage: 149.49164857190115  bits https://no.wikipedia.org/w/index.php?title=Bruker:Jeblad&action=edit&debug=1 wmE-sS-sessionId
index.p...debug=1 (line 65)
2
did not find .infobox or .infoboks
load.ph...WmIJl0K (line 13265)
mw.inspect: reports are not available in debug mode.
load.ph...WmIJl0K (line 13265)
Exception in load-callback in module mediawiki.inspect:
load.ph...WmIJl0K (line 13082)
TypeError: mw.inspect.getDependencyGraph(...)['ext.guidedTour'] is undefined
	

...spect' ).done( function () { console.log( mw.inspect.getDependencyGraph()['ext.g...

load.ph...WmIJl0K (line 13088)
title: Jeblad
load.ph...WmIJl0K (line 13265)
not a special page, terminates
load.ph...WmIJl0K (line 13265)
not in a content namespace, terminates
load.ph...WmIJl0K (line 13265)

Going back to Firefox at the Ubuntu box the bug is gone again... o_O Yet now Firefox reports version 44.0

When the bug is visible on the Ubuntu box it is visible in Firefox, Chromium and Vivaldi.

Found hi-entropy localStorage: 149.49164857190115  bits https://no.wikipedia.org/w/index.php?title=Bruker:Jeblad&action=edit&debug=1 wmE-sS-sessionId
index.p...debug=1 (line 65)
2
did not find .infobox or .infoboks
load.ph...WmIJl0K (line 13265)
mw.inspect: reports are not available in debug mode.
load.ph...WmIJl0K (line 13265)
Exception in load-callback in module mediawiki.inspect:
load.ph...WmIJl0K (line 13082)
TypeError: mw.inspect.getDependencyGraph(...)['ext.guidedTour'] is undefined
	

...spect' ).done( function () { console.log( mw.inspect.getDependencyGraph()['ext.g...

load.ph...WmIJl0K (line 13088)
not a special page, terminates
load.ph...WmIJl0K (line 13265)
not in a content namespace, terminates
load.ph...WmIJl0K (line 13265)
title: Jeblad
load.ph...WmIJl0K (line 13265)

On a different page (Bagn) and no debug

TypeError: mw.inspect.getDependencyGraph(...)['ext.guidedTour'] is undefined
https://no.wikipedia.org/w/load.php?debug=false&lang=nb&modules=jquery%2Cmediawiki&only=scripts&skin=vector&version=vWmIJl0K line 4 > eval
Line 1

Doesn't seem like 'ext.guidedTour' is defined.

If you get the error again, run (in the console):

mw.loader.getState( 'ext.guidedTour' )

I expect it will say 'error'.

When the error is *not* there, run the same thing. It should say 'registered' (which means, 'the system knows about this module, but no one asked to run it'). If it says 'ready', that means it successfully loaded (in which case then run the getDependencyGraph to try to see what loaded it).

Also, when the error happens:

Go to about:preferences#privacy , click 'remove individual cookies', then search for nowiki-mw-tour . If it's there, post a screenshot of it.

Thanks.

Seems like Freddy is back...

mw.loader.getState( 'ext.guidedTour' ) 
"registered"

mw.loader.using( 'mediawiki.inspect' ).done( func...encyGraph()['ext.guidedTour'].requiredBy ); } );

  Object { state=function(),  always=function(),  then=function(),  more...}
  Exception in load-callback in module mediawiki.inspect:
  load.ph...4Owe2Rm (line 177)
  TypeError: mw.inspect.getDependencyGraph(...)['ext.guidedTour'] is undefined
	

  ...ion"){if(!options.unique||!self.has(arg)){list.push(arg);}}else if(arg&&arg.leng...

Here it is with &debug=1

mw.loader.using( 'mediawiki.inspect' ).done( func...encyGraph()['ext.guidedTour'].requiredBy ); } );
Object { state=function(),  always=function(),  then=function(),  more...}
mw.inspect: reports are not available in debug mode.
load.ph...4Owe2Rm (line 13269)
Exception in load-callback in module mediawiki.inspect:
load.ph...4Owe2Rm (line 13086)
TypeError: mw.inspect.getDependencyGraph(...)['ext.guidedTour'] is undefined
	

...list[ firingIndex ].apply( data[ 0 ], data[ 1 ] ) === false && options.stopOnFal...

Possibly related thread Wikipedia:Torget#Hjelp. One user had messed up his common-js-page, but other than that I can't find anything strange.

Mattflaschen-WMF added a comment.EditedMar 1 2016, 12:33 AM

Let me know if you find a way to consistently reproduce it (it might depend on preferences, etc.).

To avoid the requiredBy causing an error if GuidedTour is not loaded, instead use (not in debug mode):

if ( !mw.config.get( 'debug' ) ) { mw.loader.using( 'mediawiki.inspect' ).done( function () { var graph = mw.inspect.getDependencyGraph(); if ( graph['ext.guidedTour'] ) { console.log( graph['ext.guidedTour'].requiredBy ); } else { console.log( "GuidedTour not loaded."); } } ); }

That will either show what loaded it, or just note that nothing has loaded that module.

Then, copy the actual error you're seeing from debug mode.

https://phabricator.wikimedia.org/T125793#2028722 looks like a minified version of https://git.wikimedia.org/blob/mediawiki%2Fcore.git/master/resources%2Fsrc%2Fjquery%2Fjquery.accessKeyLabel.js#L117 , but I don't know the connection.

jeblad added a comment.Mar 7 2016, 8:19 AM

The bug has been gone for several days now,.. Sort of miss it...

Mattflaschen-WMF closed this task as Resolved.Mar 25 2016, 7:06 PM

Okay, please reopen if it occurs again. Hopefully this is the last time I say that. :)