Page MenuHomePhabricator

Grammar rules inappropriately applied to MediaWiki:Mobile-frontend-placeholder in Latin language (la)
Closed, ResolvedPublic

Description

Observed behaviour: When I view any page on la.m.wikipedia.org (= the mobile site of la.wikipedia) with Latin as user interface language, the text near the very top of the screen that invites me to search reads "Quaerere apud Vicipaediommunia".
Expected behaviour: This text should read not "Quaerere apud Vicipaediommunia", but "Quaerere apud Vicipaediam".

This text apparently comes from the message MediaWiki:Mobile-frontend-placeholder. Viewing this message in the desktop view (https://la.wikipedia.org/wiki/MediaWiki:Mobile-frontend-placeholder) correctly shows "Quaerere apud Vicipaediam". Viewing this message in the mobile view (https://la.m.wikipedia.org/wiki/MediaWiki:Mobile-frontend-placeholder) illustrates the problem: While the message itself correctly reads "Quaerere apud Vicipaediam", the text near the top of the screen nevertheless incorrectly reads "Quaerere apud Vicipaediommunia".

I suspect that some grammar rules from languages/classes/LanguageLa.php get incorrectly applied to this message, but I do not understand why.

Note that a similar problem applies to other sites as well when the Latin language (la) is selected as user interface language. For example, https://fr.m.wikipedia.org/wiki/MediaWiki:Mobile-frontend-placeholder?uselang=la incorrectly shows "Quaerere apud Wikipédiommunia" near the top of the screen.

Event Timeline

UV created this task.Feb 5 2016, 9:39 PM
UV raised the priority of this task from to Needs Triage.
UV updated the task description. (Show Details)
UV added a subscriber: UV.
Restricted Application added subscribers: StudiesWorld, Aklapper. · View Herald TranscriptFeb 5 2016, 9:39 PM

Is not it a matter of using the correct case. Currently the accusative case is used.

	"mobile-frontend-placeholder": "Quaerere apud {{grammar:accusative|{{SITENAME}}}}",
	"mobile-frontend-placeholder-beta": "Quaerere apud {{grammar:accusative|{{SITENAME}}}} (Beta)",

In what case is "Vicipaediam"?

bd808 triaged this task as Low priority.Feb 8 2016, 6:10 PM
bd808 added a subscriber: bd808.
UV added a comment.Feb 8 2016, 7:33 PM

In what case is "Vicipaediam"?

"Vicipaediam" is correct, it is the accusative case.
"Vicipaediommunia" is incorrect.

Jdlrobson moved this task from Backlog to Bugs on the MobileFrontend board.Feb 18 2016, 6:29 PM

When I view any page on la.m.wikipedia.org (= the mobile site of la.wikipedia) with Latin as user interface language, the text near the very top of the screen that invites me to search reads "Quaerere apud Vicipaediommunia".

For example, https://fr.m.wikipedia.org/wiki/MediaWiki:Mobile-frontend-placeholder?uselang=la incorrectly shows "Quaerere apud Wikipédiommunia" near the top of the screen.

Can you still reproduce, @UV? I can't.

https://fr.m.wikipedia.org/wiki/MediaWiki:Mobile-frontend-placeholder?uselang=la incorrectly shows "Quaerere apud Wikipédiommunia"

Now I see "Quaerere apud Wikipédiam" which is a funny crossover of romance languages and arguably very correct (Scipio approves).

bd808 removed a subscriber: bd808.May 23 2016, 3:08 PM
UV closed this task as Resolved.May 23 2016, 7:52 PM
UV claimed this task.

Can you still reproduce, @UV? I can't.

No, I cannot reproduce any more. The text now reads "Quaerere apud Vicipaediam". Changing status to "resolved".