Page MenuHomePhabricator

GoogleLogin doesn't work with BlueSpice extension/plugin/skin
Closed, InvalidPublic

Description

Hi,

I have installed BlueSpice plugin to my mediawiki and now the google login plugin doesn't let my wiki to work at all with BlueSpice. whenever i try to login i get a 500 error. when i disable the GoogleLogin plugin then my wiki works very fine with BlueSpice.

Event Timeline

Khan.tauseef updated the task description. (Show Details)
Khan.tauseef raised the priority of this task from to Needs Triage.
Khan.tauseef added a project: GoogleLogin.
Khan.tauseef added a subscriber: Khan.tauseef.
Restricted Application added subscribers: StudiesWorld, Florian, Aklapper. · View Herald TranscriptFeb 7 2016, 12:06 PM

ofcourse BlueSpiceExtension

I can't reproduce your problem. I've downloaded BlueSpiceExtensions and BlueSpiceFoundation and installed both with:

require_once("$IP/extensions/BlueSpiceFoundation/BlueSpiceFoundation.php");
require_once("$IP/extensions/BlueSpiceExtensions/BlueSpiceExtensions.php");

without any further setup. I can still click on the login button and I see the login page. So please look into your server logs to find further information about the 500 error (what is the error message logged?) and maybe check your setup of the BlueSpice extensions :)

2016/02/07 19:49:07 [error] 7983#0: *27223 FastCGI sent in stderr: "PHP message: PHP Fatal error: Cannot redeclare class UserPreferences in /var/www/deploys/wiki2/extensions/BlueSpiceExtensions/UserPreferences/UserPreferences.class.php on line 227" while reading response header from upstream, client: 82.82.189.99, server: wiki2.spotcap.com, request: "GET /index.php?title=Main_Page HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock:", host: "wiki2.spotcap.com", referrer: "https://wiki2.spotcap.com/index.php?title=Special:UserLogin"

Florian closed this task as Invalid.Feb 7 2016, 8:49 PM
Florian claimed this task.
PHP Fatal error: Cannot redeclare class UserPreferences in /var/www/deploys/wiki2/extensions/BlueSpiceExtensions/UserPreferences/UserPreferences.class.php on line 227

That's an php exception, and because of the fact, that GoogleLogin and the Google API client doesn't implement a class UserPreferences, I assume, that this is an issue of the BlueSpiceExtensions extension, not from GoogleLogin :)

PHP Fatal error: Cannot redeclare class UserPreferences in /var/www/deploys/wiki2/extensions/BlueSpiceExtensions/UserPreferences/UserPreferences.class.php on line 227

That's an php exception, and because of the fact, that GoogleLogin and the Google API client doesn't implement a class UserPreferences, I assume, that this is an issue of the BlueSpiceExtensions extension, not from GoogleLogin :)

But when I remove the GoogleLogin plugin form my wiki then it works very fine with BlueSpice. Also, I am using normal login and getting this error but only when the GoogleLogin plugin is enabled.

Ok, when I click on the "Login" button on the login page, I'll get this exception, too, but it doesn't matter if GoogleLogin is installed or not. Could you check this again, please? I just can't reproduce the problem. Maybe it's related to other extensions, could you uninstall all other extensions?

Ok, when I click on the "Login" button on the login page, I'll get this exception, too, but it doesn't matter if GoogleLogin is installed or not. Could you check this again, please? I just can't reproduce the problem. Maybe it's related to other extensions, could you uninstall all other extensions?

Hi Florian,

I have disabled the GoogleLogin and checked the error logs again. There are no errors when GoogleLogin extension is disabled.

BlueSpice free extension version 2.23.2 and mediawiki 1.26

Johsthao closed this task as a duplicate of T126250: <spam>.Feb 8 2016, 6:24 PM
matmarex reopened this task as Open.Feb 8 2016, 6:32 PM

Ok, I took some time to test again with your specifications (even if I still think, that this is related to the BlueSpice extension). First of all, if I use the latest REL1_26 branch of MediaWIki (which is MediaWiki 1.26.x) and the BlueSpice free extension 2.23.2 (installing BlueSpiceFoundation and BlueSpiceExtensions only), I get (without any other extension installed) the following exceptions:

MediaWiki internal error.

Original exception: [a2c0c95b] /wiki/TestSections MWException from line 182 of /var/www/html/w/includes/Hooks.php: Invalid callback Flexiskin::onSkinTemplateOutputPageBeforeExec in hooks for SkinTemplateOutputPageBeforeExec

Backtrace:
#0 /var/www/html/w/includes/skins/SkinTemplate.php(472): Hooks::run(string, array)
#1 /var/www/html/w/includes/skins/SkinTemplate.php(240): SkinTemplate->prepareQuickTemplate(OutputPage)
#2 /var/www/html/w/includes/OutputPage.php(2314): SkinTemplate->outputPage()
#3 /var/www/html/w/includes/MediaWiki.php(690): OutputPage->output()
#4 /var/www/html/w/includes/MediaWiki.php(476): MediaWiki->main()
#5 /var/www/html/w/index.php(41): MediaWiki->run()
#6 {main}

Exception caught inside exception handler: [65b77de1] /wiki/TestSections MWException from line 182 of /var/www/html/w/includes/Hooks.php: Invalid callback Flexiskin::onSkinTemplateOutputPageBeforeExec in hooks for SkinTemplateOutputPageBeforeExec

Backtrace:
#0 /var/www/html/w/includes/skins/SkinTemplate.php(472): Hooks::run(string, array)
#1 /var/www/html/w/includes/skins/SkinTemplate.php(240): SkinTemplate->prepareQuickTemplate(OutputPage)
#2 /var/www/html/w/includes/OutputPage.php(2314): SkinTemplate->outputPage()
#3 /var/www/html/w/includes/exception/MWException.php(204): OutputPage->output()
#4 /var/www/html/w/includes/exception/MWException.php(244): MWException->reportHTML()
#5 /var/www/html/w/includes/exception/MWExceptionHandler.php(69): MWException->report()
#6 /var/www/html/w/includes/exception/MWExceptionHandler.php(180): MWExceptionHandler::report(MWException)
#7 /var/www/html/w/includes/MediaWiki.php(485): MWExceptionHandler::handleException(MWException)
#8 /var/www/html/w/index.php(41): MediaWiki->run()
#9 {main}

After removing Flexiskin from the setup file, I could test your use case again and couldn't reproduce your problem, also, this time I don't get an exception when clicking login at all. I could login with Google and username/password without any problems. Please give some more information, e.g. what settings you set and so on. However, I think your problem is better placed on a support desk :]

Ok, I took some time to test again with your specifications (even if I still think, that this is related to the BlueSpice extension). First of all, if I use the latest REL1_26 branch of MediaWIki (which is MediaWiki 1.26.x) and the BlueSpice free extension 2.23.2 (installing BlueSpiceFoundation and BlueSpiceExtensions only), I get (without any other extension installed) the following exceptions:

MediaWiki internal error.

Original exception: [a2c0c95b] /wiki/TestSections MWException from line 182 of /var/www/html/w/includes/Hooks.php: Invalid callback Flexiskin::onSkinTemplateOutputPageBeforeExec in hooks for SkinTemplateOutputPageBeforeExec

Backtrace:
#0 /var/www/html/w/includes/skins/SkinTemplate.php(472): Hooks::run(string, array)
#1 /var/www/html/w/includes/skins/SkinTemplate.php(240): SkinTemplate->prepareQuickTemplate(OutputPage)
#2 /var/www/html/w/includes/OutputPage.php(2314): SkinTemplate->outputPage()
#3 /var/www/html/w/includes/MediaWiki.php(690): OutputPage->output()
#4 /var/www/html/w/includes/MediaWiki.php(476): MediaWiki->main()
#5 /var/www/html/w/index.php(41): MediaWiki->run()
#6 {main}

Exception caught inside exception handler: [65b77de1] /wiki/TestSections MWException from line 182 of /var/www/html/w/includes/Hooks.php: Invalid callback Flexiskin::onSkinTemplateOutputPageBeforeExec in hooks for SkinTemplateOutputPageBeforeExec

Backtrace:
#0 /var/www/html/w/includes/skins/SkinTemplate.php(472): Hooks::run(string, array)
#1 /var/www/html/w/includes/skins/SkinTemplate.php(240): SkinTemplate->prepareQuickTemplate(OutputPage)
#2 /var/www/html/w/includes/OutputPage.php(2314): SkinTemplate->outputPage()
#3 /var/www/html/w/includes/exception/MWException.php(204): OutputPage->output()
#4 /var/www/html/w/includes/exception/MWException.php(244): MWException->reportHTML()
#5 /var/www/html/w/includes/exception/MWExceptionHandler.php(69): MWException->report()
#6 /var/www/html/w/includes/exception/MWExceptionHandler.php(180): MWExceptionHandler::report(MWException)
#7 /var/www/html/w/includes/MediaWiki.php(485): MWExceptionHandler::handleException(MWException)
#8 /var/www/html/w/index.php(41): MediaWiki->run()
#9 {main}

After removing Flexiskin from the setup file, I could test your use case again and couldn't reproduce your problem, also, this time I don't get an exception when clicking login at all. I could login with Google and username/password without any problems. Please give some more information, e.g. what settings you set and so on. However, I think your problem is better placed on a support desk :]

Ok, I took some time to test again with your specifications (even if I still think, that this is related to the BlueSpice extension). First of all, if I use the latest REL1_26 branch of MediaWIki (which is MediaWiki 1.26.x) and the BlueSpice free extension 2.23.2 (installing BlueSpiceFoundation and BlueSpiceExtensions only), I get (without any other extension installed) the following exceptions:

MediaWiki internal error.

Original exception: [a2c0c95b] /wiki/TestSections MWException from line 182 of /var/www/html/w/includes/Hooks.php: Invalid callback Flexiskin::onSkinTemplateOutputPageBeforeExec in hooks for SkinTemplateOutputPageBeforeExec

Backtrace:
#0 /var/www/html/w/includes/skins/SkinTemplate.php(472): Hooks::run(string, array)
#1 /var/www/html/w/includes/skins/SkinTemplate.php(240): SkinTemplate->prepareQuickTemplate(OutputPage)
#2 /var/www/html/w/includes/OutputPage.php(2314): SkinTemplate->outputPage()
#3 /var/www/html/w/includes/MediaWiki.php(690): OutputPage->output()
#4 /var/www/html/w/includes/MediaWiki.php(476): MediaWiki->main()
#5 /var/www/html/w/index.php(41): MediaWiki->run()
#6 {main}

Exception caught inside exception handler: [65b77de1] /wiki/TestSections MWException from line 182 of /var/www/html/w/includes/Hooks.php: Invalid callback Flexiskin::onSkinTemplateOutputPageBeforeExec in hooks for SkinTemplateOutputPageBeforeExec

Backtrace:
#0 /var/www/html/w/includes/skins/SkinTemplate.php(472): Hooks::run(string, array)
#1 /var/www/html/w/includes/skins/SkinTemplate.php(240): SkinTemplate->prepareQuickTemplate(OutputPage)
#2 /var/www/html/w/includes/OutputPage.php(2314): SkinTemplate->outputPage()
#3 /var/www/html/w/includes/exception/MWException.php(204): OutputPage->output()
#4 /var/www/html/w/includes/exception/MWException.php(244): MWException->reportHTML()
#5 /var/www/html/w/includes/exception/MWExceptionHandler.php(69): MWException->report()
#6 /var/www/html/w/includes/exception/MWExceptionHandler.php(180): MWExceptionHandler::report(MWException)
#7 /var/www/html/w/includes/MediaWiki.php(485): MWExceptionHandler::handleException(MWException)
#8 /var/www/html/w/index.php(41): MediaWiki->run()
#9 {main}

After removing Flexiskin from the setup file, I could test your use case again and couldn't reproduce your problem, also, this time I don't get an exception when clicking login at all. I could login with Google and username/password without any problems. Please give some more information, e.g. what settings you set and so on. However, I think your problem is better placed on a support desk :]

I used this one and it works. I am not getting any such exception

https://help.bluespice.com/index.php/BlueSpice_2.23/Installation_Manual/Without_Installer

[ Please avoid quoting entire previous comments, but instead strip unneeded lines. Thank you. ]

Florian closed this task as Invalid.Feb 9 2016, 3:36 PM

That's exactly the same as I used. Like I said: I would suggest to open a support desk question or ask the creators of BlueSpice (I think, that if you remove the BlueSpice extensions from your wiki, GoogleLogin will work without any problem?), as I can't reproduce the problem and BlueSpice is a huge extension/set of extensions, that changes so many things, that I've to assume, that the problem is inside of one of these extensions. Sorry, that I can't assist you, but without the ability to reproduce the problem, I can't track the problem down :(