Page MenuHomePhabricator

Zooming images doesn't work in the latest beta release
Closed, ResolvedPublic

Description

Description

If you try to zoom in or out any image in the latest Wikipedia beta release, it doesn't work anymore (no reaction, it seems, that the pinch to zoom gesture is interpreted as a simple tap, as the caption of the image appears and disappears when you try to zoom). The same image(s) works without any problem in the stable version. The same problem can be reproduced in the alpha version.

Originally reported at https://ticket.wikimedia.org/otrs/index.pl?Action=AgentTicketZoom;TicketID=8969931

Steps to reproduce

  1. Open a page with images (e.g. "Quasar" in the english Wikipedia)
  2. Tap on an image
  3. Try to zoom with a pinch to zoom gesture

Expected results

The image zooms-in or out (depending on the used gesture)

Actual results

The gesture is interpreted as a tap, the caption appears or disappears (depending on the current state of it).

Environments observed

App version: 2.1.140-beta-2016-02-04
Android OS versions: Android 6.0
Device model: HTC One M9
Device language: german (article in english)

Event Timeline

Florian created this task.Feb 7 2016, 5:05 PM
Florian raised the priority of this task from to Needs Triage.
Florian updated the task description. (Show Details)
Florian added a subscriber: Florian.
Restricted Application added subscribers: StudiesWorld, Aklapper. · View Herald TranscriptFeb 7 2016, 5:05 PM
Johsthao closed this task as a duplicate of T126250: <spam>.Feb 8 2016, 6:24 PM
JEumerus reopened this task as Open.Feb 8 2016, 6:31 PM
JEumerus set Security to None.

Change 269891 had a related patch set uploaded (by Dbrant):
Bring back pinch-to-zoom in gallery.

https://gerrit.wikimedia.org/r/269891

Change 269891 merged by jenkins-bot:
Bring back pinch-to-zoom in gallery.

https://gerrit.wikimedia.org/r/269891

Checked with 2.1.141-alpha-2016-02-12 on Nexus 5 (Android 5.1.1) - pinch-to-zoom works(even for animated images).

Dbrant closed this task as Resolved.Feb 12 2016, 6:53 PM