Page MenuHomePhabricator

Toollabs::Cronrunner backup fails for invalid utf-8 content
Closed, ResolvedPublic

Description

valhallasw@tools-bastion-01:/etc/salt$ ssh tools-cron-01 sudo tail /var/log/puppet.log
Info: Loading facts in /var/lib/puppet/lib/facter/physicalcorecount.rb
Info: Loading facts in /var/lib/puppet/lib/facter/ganeti.rb
Info: Loading facts in /var/lib/puppet/lib/facter/initsystem.rb
Info: Loading facts in /var/lib/puppet/lib/facter/puppet_config_dir.rb
Info: Loading facts in /var/lib/puppet/lib/facter/apt.rb
Info: Caching catalog for tools-cron-01.tools.eqiad.wmflabs
Info: Applying configuration version '1454864797'
Error: invalid byte sequence in UTF-8
Error: /Stage[main]/Toollabs::Cronrunner/File[/data/project/.system/crontabs/tools-cron-01.tools.eqiad.wmflabs/tools.ato]/content: change from {md5}e926f1541f7d98c2793a6d7748c86205 to {md5}d92fae4e6dafb7a161238dac4d1e98e2 failed: invalid byte sequence in UTF-8
Notice: Finished catalog run in 94.98 seconds

Event Timeline

valhallasw raised the priority of this task from to Needs Triage.
valhallasw updated the task description. (Show Details)
scfc claimed this task.Feb 7 2016, 7:53 PM
scfc added a subscriber: scfc.

I believe this is essentially https://tickets.puppetlabs.com/browse/PUP-3377https://tickets.puppetlabs.com/browse/PUP-1441. I'll test that and, if so, fix it by show_diff => false.

scfc added a comment.Feb 7 2016, 9:07 PM

Yep, show_diff => false works.

scfc closed this task as Resolved.Feb 7 2016, 11:05 PM

Fixed by 6a2e3d9acbc75089b04384387f4d162107933ca8 where I missed adding the "Bug:" footer.

Johsthao closed this task as a duplicate of T126250: <spam>.Feb 8 2016, 6:24 PM
JEumerus changed the task status from Duplicate to Resolved.Feb 8 2016, 6:31 PM
JEumerus set Security to None.
matmarex reopened this task as Open.Feb 8 2016, 6:32 PM
scfc closed this task as Resolved.Feb 8 2016, 7:22 PM