Page MenuHomePhabricator

tools-exec-12* puppet broken: php5* packages have been upgraded again?
Closed, ResolvedPublic

Description

Error: /Stage[main]/Toollabs::Exec_environ/Package[php5-intl]/ensure: change from 5.3.10-1ubuntu3.21 to 5.3.10-1ubuntu3.20+wmf1 failed: Could not update: Execution of '/usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold install php5-intl' returned 100: Reading package lists...
Building dependency tree...
Reading state information...
The following packages were automatically installed and are no longer required:
  python-greenlet linux-image-3.2.0-96-virtual python-gevent python-mailer
  python-gdbm
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  libapache2-mod-php5filter php-pear php5-cli php5-common php5-curl php5-gd
  php5-mysql php5-pgsql php5-sqlite php5-xsl
Suggested packages:
  php5-suhosin
Recommended packages:
  php5-dev
The following packages will be DOWNGRADED:
  libapache2-mod-php5filter php-pear php5-cli php5-common php5-curl php5-gd
  php5-intl php5-mysql php5-pgsql php5-sqlite php5-xsl
0 upgraded, 0 newly installed, 11 downgraded, 0 to remove and 43 not upgraded.
Need to get 368 kB/7199 kB of archives.
After this operation, 1692 kB disk space will be freed.
E: There are problems and -y was used without --force-yes

Event Timeline

valhallasw raised the priority of this task from to Needs Triage.
valhallasw updated the task description. (Show Details)
valhallasw added a project: Toolforge.
valhallasw added a subscriber: valhallasw.
Restricted Application added a project: Cloud-Services. · View Herald TranscriptFeb 8 2016, 10:12 AM
Restricted Application added subscribers: StudiesWorld, Aklapper. · View Herald Transcript
Johsthao closed this task as a duplicate of T126250: <spam>.Feb 8 2016, 6:24 PM
matmarex reopened this task as Open.Feb 8 2016, 6:32 PM

I'm just ran `apt-get install -y --force-yes libapache2-mod-php5filter php-pear php5-cli php5-common php5-curl php5-gd php5-intl php5-mysql php5-pgsql php5-sqlite php5-xsl``` on the affected hosts, and will have forced a puppet run on each. There seems to be issues other than this one on some hosts, which is next on my list...

chasemp closed this task as Resolved.Apr 4 2016, 2:44 PM
chasemp added a subscriber: chasemp.

can't reproduce this anymore