Page MenuHomePhabricator

Reach out communities to build the list of templates that should be included in the ranking formula
Closed, DeclinedPublic

Description

Boost templates is a feature that allows pages to be ranked higher/lower in the search results.
This feature is currently activated on enwiki via a System message.
The purpose of this task is:

1. Prioritize wikis
We host many wikis, some of them are very small and may not benefit from this feature, such features are useful only when queries return a high number of results. IMHO we should first reach out communities that work on large wikis. (boost templates for enwiki should be reviewed).

2. Define the output and reach out communities
The purpose of the boost templates feature is to include a criteria that reflects the quality of page.
Most wikis uses templates to flag such information, we should maybe reuse the definition used by ORES wp10 based on Version_1.0_Editorial_Team or Assessment.
The output would be the list of templates that correspond to each element in the scale.
Example for the french wikipedia:

ScaleTemplate
FAModèle:Article_de_qualité
GAModèle:Bon_article
......
NOTE: we don't need the communities to define the precise weights, we will use the relevancy lab to adjust them.

Event Timeline

dcausse created this task.Feb 8 2016, 11:33 AM
dcausse updated the task description. (Show Details)
dcausse raised the priority of this task from to Normal.
dcausse added projects: CirrusSearch, Discovery, Epic.
Johsthao closed this task as a duplicate of T126250: <spam>.Feb 8 2016, 6:24 PM
matmarex reopened this task as Open.Feb 8 2016, 6:32 PM
CKoerner_WMF set Security to None.

Being bold and claiming this task (until someone tells me otherwise).

@CKoerner_WMF Go for it! Let me know if you need any more info to move on this.

EBernhardson moved this task from Needs triage to Search on the Discovery board.Feb 11 2016, 11:18 PM

"Most wikis uses templates to flag such information": [dubious – discuss]?

Very, very few Wikipedias have ratings for most of their articles. Most have never had anything more than a Featured Article and perhaps a Good/Recommended Article rating (and I believe that those ratings are already available via Wikidata). I'm not sure that a majority of projects even have a functional Featured Article process right now. Even at the English Wikipedia, about 10% have no assessment and a significant fraction of articles have out-of-date assessments.

If your goal is to get non-English content, then IMO you should focus on automated, universal RevScoring services.

@Whatamidoing-WMF: thanks for the heads up.
The goal is to review the current features enabled in cirrus and "boost templates" is one of them.
We are extremely interested by ORES WP10 but we don't have an easy way to integrate such data in the index for the moment, boost templates exists and is ready to use.

Restricted Application added a project: Discovery-Search. · View Herald TranscriptMay 10 2016, 4:27 PM

Let's hold off on this right now, pending an investigation of the suitability of incorporating ORES rankings instead (which basically does exactly what this task wants more generically, and through a different mechanism).

Deskana changed the task status from Open to Stalled.May 12 2016, 10:09 PM
Deskana moved this task from needs triage to This Quarter on the Discovery-Search board.
debt moved this task from This Quarter to later on... on the Discovery-Search board.EditedJun 2 2016, 10:11 PM
debt added a subscriber: debt.

Moving this to later - we'll pick it up when we get more information from the ORES team. Will probably work on this in Q1.

CKoerner_WMF lowered the priority of this task from Normal to Low.Jul 5 2016, 9:43 PM
CKoerner_WMF removed CKoerner_WMF as the assignee of this task.Oct 2 2017, 4:55 PM

I'm going to unassign for now, but happy to help if/when work picks up again.

debt closed this task as Declined.Oct 26 2017, 5:23 PM

We think this was only used on enwiki but it's turned off now due to the upgrades that came with machine learning. Not really relevant any more and adding ORES rankings didn't make any noticeable improvements.