Page MenuHomePhabricator

Revisit IRC notification strategy for WebPageTest
Closed, ResolvedPublic

Description

There are a couple of problems with the IRC notifications created by WebPageTest jobs in Jenkins.

The idea from the beginning was to know if the jobs failed: catch a bad push or when WebPageTest stopped working a a couple of weeks ago when our agent freezed and couldn't be contacted by the server.

However we also get notifications when the WebPageTest.org test with real 2G/3G connections fails (and that happens quite often) and when the test environment has content that returns 400.

I think we could have IRC notifications turned on only for our own instance (so we know that it works) and that we only test URL in productions that have the right content.

Lets sync tonight at our meeting.

Event Timeline

Peter created this task.Feb 8 2016, 1:43 PM
Peter updated the task description. (Show Details)
Peter raised the priority of this task from to Needs Triage.
Peter claimed this task.
Peter added a project: Performance-Team.
Peter added a subscriber: Peter.
Restricted Application added subscribers: StudiesWorld, Aklapper. · View Herald TranscriptFeb 8 2016, 1:43 PM
Johsthao closed this task as a duplicate of T126250: <spam>.Feb 8 2016, 6:24 PM
matmarex reopened this task as Open.Feb 8 2016, 6:32 PM
ori added a subscriber: ori.Feb 8 2016, 7:50 PM

Should we perhaps keep bots on a parallel channel, like #wikimedia-perf-announce?

ori triaged this task as Normal priority.Feb 8 2016, 7:51 PM
ori set Security to None.
ori moved this task from Inbox to Backlog: Small & Maintenance on the Performance-Team board.
Peter lowered the priority of this task from Normal to Low.Dec 7 2016, 5:28 PM
Peter removed Peter as the assignee of this task.
Gilles added a subscriber: Gilles.Jun 21 2017, 2:04 PM

We should move this to perf-bots. I think we should probably point wikibugs there as well. This way -perf would be exclusively for human discussion. I think it would make the channel more inviting, at the moment those two bots dominate the output.

Change 360875 had a related patch set uploaded (by Krinkle; owner: Phedenskog):
[integration/config@master] Publish WebPageTest job status to wikimedia-perf-bots

https://gerrit.wikimedia.org/r/360875

Krinkle closed this task as Resolved.Jun 26 2017, 9:01 PM
Krinkle assigned this task to Peter.
Krinkle moved this task from Backlog: Small & Maintenance to Doing on the Performance-Team board.

Change 360875 merged by jenkins-bot:
[integration/config@master] Publish WebPageTest job status to wikimedia-perf-bots

https://gerrit.wikimedia.org/r/360875