Page MenuHomePhabricator

Gadgets not appearing in [[Special:Gadgets]] on no.wikimedia.org
Closed, DuplicatePublic

Description

I've defined a couple of gadgets in [1], but they don't appear in [[Special:Gadgets]] [2] as one would expect. I have tried with simpler commands, but nothing seems to work. Everything related to gadgets in [[Special:Version]] seems to be the same as Meta and no.wikipedia.org, so I have no idea what's wrong.

[1] https://no.wikimedia.org/wiki/MediaWiki:Gadgets-definition
[2] https://no.wikimedia.org/wiki/Spesial:Tilleggsfunksjoner

Event Timeline

jhsoby created this task.Feb 8 2016, 2:27 PM
jhsoby updated the task description. (Show Details)
jhsoby raised the priority of this task from to Needs Triage.
jhsoby added a subscriber: jhsoby.
Restricted Application added subscribers: StudiesWorld, Aklapper. · View Herald TranscriptFeb 8 2016, 2:27 PM
Krenair added a subscriber: Krenair.EditedFeb 8 2016, 2:47 PM

echo 'GadgetRepo::singleton()->purgeDefinitionCache();' | ssh terbium mwscript eval.php nowikimedia seems to have fixed it... Well, hidden the problem. :/

jhsoby closed this task as Resolved.Feb 8 2016, 2:57 PM
jhsoby claimed this task.

One desperate and illogical attempt later I made it work. By putting the stuff in [1] instead it worked. We had the same problem with T119998. I don't know why this works, but it the important thing is that it works.

[1] https://no.wikimedia.org/wiki/MediaWiki:Gadgets-definition/nb

Johsthao closed this task as a duplicate of T126250: <spam>.Feb 8 2016, 6:24 PM
matmarex reopened this task as Open.Feb 8 2016, 6:32 PM