Page MenuHomePhabricator

[Crash] IllegalStateException in ListView.layoutChildren()
Closed, ResolvedPublic

Description

https://rink.hockeyapp.net/manage/apps/226650/app_versions/11/crash_reasons/110316025

java.lang.IllegalStateException: The content of the adapter has changed but ListView did not receive a notification. Make sure the content of your adapter is not modified from a background thread, but only from the UI thread. Make sure your adapter calls notifyDataSetChanged() when its content changes. [in ListView(2131624117, class android.widget.ListView) with Adapter(class org.wikipedia.page.tabs.TabsProvider$TabListAdapter)]
at android.widget.ListView.layoutChildren(ListView.java:1562)
at android.widget.AbsListView.onTouchModeChanged(AbsListView.java:3569)
at android.view.ViewTreeObserver.dispatchOnTouchModeChanged(ViewTreeObserver.java:1001)
at android.view.ViewRootImpl.ensureTouchModeLocally(ViewRootImpl.java:3448)
at android.view.ViewRootImpl.performTraversals(ViewRootImpl.java:1771)
at android.view.ViewRootImpl.doTraversal(ViewRootImpl.java:1065)
at android.view.ViewRootImpl$TraversalRunnable.run(ViewRootImpl.java:5901)
at android.view.Choreographer$CallbackRecord.run(Choreographer.java:767)
at android.view.Choreographer.doCallbacks(Choreographer.java:580)
at android.view.Choreographer.doFrame(Choreographer.java:550)
at android.view.Choreographer$FrameDisplayEventReceiver.run(Choreographer.java:753)
at android.os.Handler.handleCallback(Handler.java:739)
at android.os.Handler.dispatchMessage(Handler.java:95)
at android.os.Looper.loop(Looper.java:211)
at android.app.ActivityThread.main(ActivityThread.java:5373)
at java.lang.reflect.Method.invoke(Native Method)
at java.lang.reflect.Method.invoke(Method.java:372)
at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:1020)
at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:815)

Event Timeline

Dbrant created this task.Feb 8 2016, 3:31 PM
Dbrant updated the task description. (Show Details)
Dbrant raised the priority of this task from to High.
Dbrant moved this task to Next Sprint on the Wikipedia-Android-App-Backlog board.
Dbrant added a subscriber: Dbrant.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 8 2016, 3:31 PM
Dbrant claimed this task.Feb 8 2016, 3:59 PM
Dbrant set Security to None.

Change 269150 had a related patch set uploaded (by Dbrant):
Fix possible crash when laying out tab list.

https://gerrit.wikimedia.org/r/269150

Change 269150 merged by jenkins-bot:
Fix possible crash when laying out tab list.

https://gerrit.wikimedia.org/r/269150

Johsthao closed this task as a duplicate of T126250: <spam>.Feb 8 2016, 6:24 PM
matmarex reopened this task as Open.Feb 8 2016, 6:32 PM

Checked adding/deleting tabs with 2.1.141-alpha-2016-02-12 on Nexus 5 (Android 5.1.1) - no crashes

Dbrant closed this task as Resolved.