Page MenuHomePhabricator

Cannot upload 12MB JPG file with Upload Wizard: "The upload succeeded, but the server could not get a preview thumbnail."
Closed, ResolvedPublic

Description

I have tried to upload large JPG files (11.5MB and 38MB) via the Upload Wizard using both Safari and Firefox on a Mac running the latest version of all System Software.

  • on the first page of the upload wizard, after a good while I get the message "The upload succeeded, but the server could not get a preview thumbnail."
  • The upload itself succeeds nevertheless and I can go to the next page via "Continue"
  • On the Release rights page, the preview item is a broken document, but I can select the license and click "Next" to proceed
  • On the Describe page, the preview item is a broken document, I can enter all fields and click "Next".
  • But at this point (right after clicking "Next"), the Wizard shortly shows the next page, but immediately falls back to the Describe page, but now the "Next" button has vanished, and there is no way to complete the upload!
  • This does not happen for smaller JPG file, and I managed to choose a lower JPG quality to get the file that was 11.5 MB (Photoshop 12) to 6.8 MB (Photoshop 11) that allowed me to upload this file. I cannot do this for the larger JPG file.

Please fix this bug!

Event Timeline

Rftblr created this task.Feb 9 2016, 12:03 AM
Rftblr raised the priority of this task from to Needs Triage.
Rftblr updated the task description. (Show Details)
Rftblr added a project: MediaWiki-General.
Rftblr added a subscriber: Rftblr.
Restricted Application added subscribers: StudiesWorld, Aklapper. · View Herald TranscriptFeb 9 2016, 12:03 AM
Restricted Application added a project: Multimedia. · View Herald TranscriptFeb 9 2016, 10:40 AM
Restricted Application added a subscriber: Steinsplitter. · View Herald Transcript
Aklapper renamed this task from Cannot upload large JPG file with Upload Wizard: "The upload succeeded, but the server could not get a preview thumbnail." to Cannot upload 12MB JPG file with Upload Wizard: "The upload succeeded, but the server could not get a preview thumbnail.".Feb 9 2016, 10:41 AM
Restricted Application added a subscriber: Matanya. · View Herald TranscriptFeb 9 2016, 10:41 AM
matmarex closed this task as Resolved.Jul 20 2016, 4:36 PM
matmarex added a subscriber: matmarex.

I'm sorry that this report went so far with no response. I think we already solved the issues you reported:

on the first page of the upload wizard, after a good while I get the message "The upload succeeded, but the server could not get a preview thumbnail."

This sounds like T130437. Or it might have been a transient issue.

But at this point (right after clicking "Next"), the Wizard shortly shows the next page, but immediately falls back to the Describe page, but now the "Next" button has vanished, and there is no way to complete the upload!

That used to happen when there was some error with your submission, error recovery was broken. I fixed it in T106968.