Page MenuHomePhabricator

Strip references from HTML on beta cluster beta mode, measure impact
Closed, ResolvedPublic3 Story Points

Description

Let's do a quick check before going down a rabbit hole to see what impact if any stripping references will have

  • Ensure this will not clash with T126558

JR: this will not be in the current sprint so we're good.
[] Disable navbox experiment (remove .navboxfrom wgMFRemovableClasses )
JR: decided not to do this as it would be an unfair test to test 7 days prior to stripping references with a completely different environment)

  • Update wgMFRemovableClasses to include .references on beta channel and stable channel of beta cluster

JR: this is now live as of Tue 16th February.

  • Update wgMFRemovableClasses to exclude .references on beta channel and stable channel of beta cluster

JR: this is now live as of Monday 22nd 5:20PM PST

  • Use script to measure impact on beta cluster post-change for webpagetest.enwiki-bc-mobile-beta-2gslow.anonymous.Barack_Obama.us-east-1.Google_Chrome-emulateMobile.firstView and webpagetest.enwiki-bc-mobile-2gslow.anonymous.Barack_Obama.us-east-1.Google_Chrome-emulateMobile.firstView

JR: Will measure Fri 27th Feb (5 days of data before and after)

  • Revert both changes after collecting 10 5-10 days worth of data (since we don't want to break sauce labs browser tests of the references feature).

JR: Wasn't necessary.

Details

Related Gerrit Patches:
operations/mediawiki-config : masterRevert "Strip references for experimentation"
operations/mediawiki-config : masterStrip references for experimentation

Related Objects

StatusAssignedTask
OpenNone
OpenNone
OpenNone
OpenNone
OpenNone
OpenNone
OpenNone
DeclinedNone
OpenNone
Resolveddr0ptp4kt
DuplicateJhernandez
Duplicatedr0ptp4kt
OpenNone
Resolved Jdlrobson
DeclinedNone
Resolved Jdlrobson

Event Timeline

Jdlrobson raised the priority of this task from to Medium.
Jdlrobson updated the task description. (Show Details)
Jdlrobson added a subscriber: Jdlrobson.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 9 2016, 10:47 PM
Jdlrobson updated the task description. (Show Details)

Change 271074 had a related patch set uploaded (by Jdlrobson):
Strip references for experimentation

https://gerrit.wikimedia.org/r/271074

Change 271074 merged by jenkins-bot:
Strip references for experimentation

https://gerrit.wikimedia.org/r/271074

This has been SWATed to the beta cluster
Unfortunately due to the unexpected srcset removal that happened earlier today this is not a fair test.

We should look to reenable hdpi images on beta cluster and ignore the period of time both were active for. Alternatively I could revert this change wait 7 days and try again. Too tired to think of best thing to do right now.

Jdlrobson changed the task status from Open to Stalled.Feb 17 2016, 7:10 PM
Jdlrobson updated the task description. (Show Details)

Updated plan. Stalled until Monday.

Change 271322 had a related patch set uploaded (by Jdlrobson):
Revert "Strip references for experimentation"

https://gerrit.wikimedia.org/r/271322

Peter added a subscriber: Peter.Feb 22 2016, 9:30 AM

Change 271322 merged by jenkins-bot:
Revert "Strip references for experimentation"

https://gerrit.wikimedia.org/r/271322

I can confirm references are now back in the HTML of beta cluster. Should soon see this in the graphs.

Jdlrobson updated the task description. (Show Details)

Hypothesis could be made clearer. For example,

Certain content doesn't necessarily need to be shipped to the user upfront and sometimes not at all.

doesn't state a reason.

And, these three lines don't have commands:

The commands used to measure the impact of the change were:
The commands used to measure the impact of the change were:
The commands used to measure the impact of the change were:

Updated per @bmansurov
@dr0ptp4kt still needs to sign off.

dr0ptp4kt closed this task as Resolved.Mar 2 2016, 10:57 PM

LGTM