Page MenuHomePhabricator

Investigate OTRS 5.0.6 memory leak
Closed, DeclinedPublic

Description

OTRS 5.0.6 is leaking memory. Creating this task to track findings, upstream reporting etc.

We 've been bit by OTRS memory leak once already. See T125756

OTRS seems to be leaking between 200MB and 250MB of RAM per hour. This is evident in

https://ganglia.wikimedia.org/latest/graph.php?r=week&z=xlarge&h=mendelevium.eqiad.wmnet&m=cpu_report&s=descending&mc=2&g=mem_report&c=Miscellaneous+eqiad

notice the "saw-like" pattern of increased memory usage, followed by a restart of apache that brings memory back down to lower levels.

Event Timeline

akosiaris claimed this task.
akosiaris raised the priority of this task from to High.
akosiaris updated the task description. (Show Details)
akosiaris added a project: Znuny.
akosiaris added a subscriber: akosiaris.

Task is closed as invalid on upstream.

@Peachey88, yes it has been quite effectively mitigated in apache (MaxConnectionsPerChild 2000). OTRS memory usage is not averaging at 3.5-3.9GB. But it is not solved nonetheless. Upstream (OTRS devs) have suggested disabling all extra packages and trying to reproduce it (alternatively trying to reproduce it in a different environment). I 've tried the latter in a labs VM but I haven't managed to reproduce the issue. The former requires a window of time during which OTRS functionality for agents will be reduced. Given the codfw transition plans for the last 2 months I 've avoided any kind of changes in OTRS, trying to not add more entropy into the mix. It is to be tried though. I don't an ETA however.

And it is quite improbable this is contributing to T132822. That one looks way more like a forever loop.

akosiaris lowered the priority of this task from High to Low.May 4 2016, 9:47 AM

Since we got a very effective mitigation in place, I am lowering priority.

I am gonna resolve this as Declined. Upstream did not verify this bug's existence and we have mitigations in place anyway.